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Good.

Not sure I can help you with the "access denied" problem.

−− 
Bruce Sanderson  MVP
It is perfectly useless to know the right answer to the wrong question.
"Gregg Hill" <bogus@nowhere.com> wrote in message 
news:%23FKRnIp3EHA.1400@TK2MSFTNGP11.phx.gbl...
> Bruce,
>
> I finally figured out why the GPO did not work the way you said it would. 
> I am brain−dead! I run SBS 2003 at home, and I have a test lab with Server 
> 2003 Standard. I was using the SBS 2003 to test, since I was trying to get 
> RPC over HTTP working on the Server 2003 lab domain at the time and did 
> not want to change any settings there.
>
> I had the GPO under the SBSUsers instead of SBSComputers when I set it up 
> using GPMC. Dang! Nothing a LOT more sleep shouldn't fix.
>
> Now to try to figure out why the GP Results wizard gives me an access 
> denied error when I run it against any computer other than the SBS 2003 
> server itself.
>
> Gregg Hill
>
>
>
>
>
>
>
> "Bruce Sanderson" <bsanders@junk.junk> wrote in message
> news:OBXLg2n3EHA.1400@TK2MSFTNGP11.phx.gbl...
>> If you set the following registry entry (using regedit) on an XP
>> workstation
>> (or Windows 2003 Server) to 0 or 1, I think you will find that the the
>> offending setting disappears from Windows Explorer for any user that logs
>> on
>> to that workstation.  0 is disable NoNetCrawling (check mark present); 1
>> is
>> enable NoNetCrawling (check mark absent).  At least, that is my 
>> experience
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>> on any Windows XP workstation or Windows Server 2003 I've tried it on.
>>
>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
>> NoNetCrawling (DWORD)
>>
>> You don't even need to logoff and logon again, just close all open 
>> Windows
>> Explorer Windows, then launch Windows Explorer.
>>
>> The above registry setting is set via GPO by the combination of:
>> 1. the ADM content from my earlier post
>> 2. a GPO with the setting
>>    Computer Configuration
>>       Administrative Templates
>>         Windows Components
>>           Windows Explorer
>>              Disable Automatically search for network folders and
>> printers: Enabled
>> 3. the above GPO linked to the OU containing the target computer
>> (workstation or server) computer account
>> 4. allow enough time for the change to be propogated to all domain
>> controllers (typically not more than a few minutes)
>> 5. restart the target computer or run the gpupdate /force command
>>
>> For GPOs linked to Computer accounts, only settings in the Computer
>> Configuration (CLASS MACHINE) part of the GPO will be effective.  For 
>> GPOs
>> linked to User Accounts, only the User Configuration (CLASS USER) part of
>> the GPO will be effective.  You can see this using the Resultant Set of
>> Policies tool in GPMC.
>>
>> Computer specific GPOs are acquired by the computer when the OS starts.
>> If
>> you change a Computer Configuration setting in a GPO after the computer 
>> is
>> started, it will not be acquired by the computer until either the
>> automatic
>> GPO refresh takes place (about every 12 hours) or the command
>>
>>    gpupdate
>>
>> is run (use gpupdate /? to get an explanation of the available options).
>>
>> I've just verified again that this works as I have described on Windows 
>> XP
>> SP2 workstations and Windows Server 2003 Enterprise Edition in a Windows
>> 2000 domain.
>>
>> The advantage of making this a "computer" policy as opposed to a "user"
>> policy is that it is applied automatically to all users that logon to the
>> computer, no matter what OU that users account is in.  It is also applied
>> to
>> those who logon using local user accounts.
>>
>> −− 
>> Bruce Sanderson  MVP
>>
>> It is perfectly useless to know the right answer to the wrong question.
>>
>>
>> "Gregg Hill" <bogus@nowhere.com> wrote in message
>> news:O0JdTMc3EHA.3616@TK2MSFTNGP11.phx.gbl...
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>>> Bruce,
>>>
>>> I think our goals were different. I was trying to find a way to do it on
>>> all computers on the network, especially the workstations. When I used
>>> your suggestion as is, it did not remove the setting from the Windows
>>> Explorer > Tools > Folder Options >View menu. My experience with this
>>> obnoxious item has been that every time a new user logs on, it is set to
>>> crawl for folders and printers. I can uncheck it for all current users,
>>> but the next new user to log on gets it again by default (prior to any
>>> GPO
>>> stuff, just a normal installation).
>>>
>>> After changing it to CLASS USER, the item is no longer on the Windows
>>> Explorer > Tools > Folder Options >View menu. I haven't tried logging
>>> into
>>> anything as a new user to see if it actually stops the crawling.
>>>
>>> I'll go look at the thread you mentioned.
>>>
>>> Thank you!
>>>
>>> Gregg Hill
>>>
>>>
>>> "Bruce Sanderson" <bsanders@junk.junk> wrote in message
>>> news:uO462Yb3EHA.2624@TK2MSFTNGP11.phx.gbl...
>>>> Having read all of this stuff again, here's some observations:
>>>>
>>>> 1. settings put into the registry key
>>>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
>>>> are applied to all users that logon to a computer.  That's why CLASS
>>>> MACHINE is used in this ADM − to set the "policy" for all users of some
>>>> computers. .  This is explained in the KB articles 330929, 812669 and
>>>> 831129. .  In the case I was interested in, the computers in question
>>>> are
>>>> Windows 2003 Servers running Terminal Services.
>>>>
>>>> 2. Settings inside CLASS MACHINE show up in the Computer Configuration
>>>> part of the GPO.  The implication is that GPOs with setting need to be
>>>> applied to OUs with the Computer Accounts these settings are to be
>>>> applied to.  This is what I did and my testing demonstrates to me that
>>>> it
>>>> works as Mark Renoden said it would in the thread with the subject
>>>> "Windows Explorer NoNetCrawling" in the newsgroup
>>>> microsoft.public.win2000.group_policy.
>>>>
>>>> 3. Using CLASS USER, adding the setting in the User Configuration part
>>>> of
>>>> a GPO and applying that GPO to User Accounts most likely accomplishes
>>>> the
>>>> same objective, but the setting then applies to specifice users
>>>> regardless of what computer they logon to, which is not quite what I
>>>> wanted to accomplish.
>>>>
>>>> 4. using GPO Loopback Processing, the CLASS USER approach as you did 
>>>> and
>>>> applying the GPO to the OU containing the Terminal Servers would most
>>>> likely accomplish what I wanted − I just didn't approach the problem
>>>> from
>>>> that direction.
>>>>
>>>> −− 
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>>>> Bruce Sanderson  MVP
>>>>
>>>> It is perfectly useless to know the right answer to the wrong question.
>>>>
>>>>
>>>> "Gregg Hill" <bogus@nowhere.com> wrote in message
>>>> news:eR5BQM12EHA.2156@TK2MSFTNGP10.phx.gbl...
>>>>> Bruce,
>>>>>
>>>>> I haven't read any articles yet, but I did try the suggested ADM that
>>>>> you showed. It does not remove the choice
>>>>>
>>>>> I was sure it was a user−specific entry, so I guessed at how to modify
>>>>> the ADM file to make it change HKCU instead of HLKM key. I changed:
>>>>>
>>>>> CLASS MACHINE ;This modifies the HKEY_LOCAL_MACHINE portion of the
>>>>> registry
>>>>> to
>>>>> CLASS USER ;This modifies the HKEY_CURRENT_USER portion of the 
>>>>> registry
>>>>>
>>>>> I then saved it.
>>>>>
>>>>> I guessed correctly and it now removes the "Automatically search for
>>>>> network folders and printers" entry from Windows Explorer. I am going
>>>>> to
>>>>> see if it works by logging on as a new user.
>>>>>
>>>>> I'll start in on those articles later this week. Thanks once again for
>>>>> all your fine help!
>>>>>
>>>>> Gregg Hill
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> "Bruce Sanderson" <bsanders@junk.junk> wrote in message
>>>>> news:urlH%23gm2EHA.1204@TK2MSFTNGP10.phx.gbl...
>>>>>>I agree: all of these "features" that attempt to keep the content of
>>>>>>Windows Explorer panes up to date are a pesky nuisance.  This is
>>>>>>particulary so in a Windows 2003 Terminal Services environment.  I
>>>>>>surely wish there was a simple way to tell Windows Explorer and
>>>>>>whatever
>>>>>>it interfaces with to completely turn off anything involved in keeping
>>>>>>the Windows Explorer contents current.  This "feature" causes lots of
>>>>>>next to useless network traffic, uses a lot of CPU time in the user's
>>>>>>session and results in the user's session being locked up for
>>>>>>frequently
>>>>>>for long periods of time.
>>>>>>
>>>>>> Unfortunately, I've not yet found a complete solution, although I 
>>>>>> have
>>>>>> made some progress.  I'd be interested in whatever you find out about
>>>>>> this.
>>>>>>
>>>>>> See these articles:
>>>>>>
>>>>>> http://support.microsoft.com/?kbid=330929
>>>>>> http://support.microsoft.com/?kbid=812669
>>>>>> http://support.microsoft.com/?kbid=816375
>>>>>> http://support.microsoft.com/default.aspx?kbid=834350
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>>>>>> http://support.microsoft.com/?kbid=831129
>>>>>>
>>>>>> To answer your original question, create a custom ADM  with the
>>>>>> content
>>>>>> shown below.  I've used this and when I enable the policy, the
>>>>>> "Automatically search for network folders and printers" disappears
>>>>>> from
>>>>>> Windows Explorer's Tools, Folder Options, View panel, but telling
>>>>>> whether or not is having the desired affect is not entirely clear.
>>>>>> See
>>>>>> http://www.microsoft.com/downloads/details.aspx?FamilyId=E7D72FA1−62FE−4358−8360−8774EA8DB847&displaylang=en
>>>>>> and http://support.microsoft.com/?kbid=323639
>>>>>> for information about building and using Custom Administrative
>>>>>> Templates.
>>>>>>
>>>>>> CLASS MACHINE ;This modifies the HKEY_LOCAL_MACHINE portion of the
>>>>>> registry
>>>>>>
>>>>>> CATEGORY !!WindowsComponents
>>>>>>  CATEGORY !!WindowsExplorer
>>>>>>     KEYNAME !!KeyMachinePoliciesExplorer
>>>>>> ; allows turning on or off Explorer, Tools, Folder Options, View,
>>>>>> Automatically search for network folders and printers
>>>>>>      POLICY !!PNoNetCrawling
>>>>>>          EXPLAIN !!ENoNetCrawling
>>>>>>          VALUENAME !!VNoNetCrawling
>>>>>>          VALUEON NUMERIC 1
>>>>>>          VALUEOFF NUMERIC 0
>>>>>>      END POLICY
>>>>>>   END CATEGORY
>>>>>> END CATEGORY
>>>>>>
>>>>>> ; the following strings section assigns character strings
>>>>>> ; to the variable names specified in the previous section
>>>>>> [strings]
>>>>>> WindowsComponents="Windows Components"
>>>>>> WindowsExplorer="Windows Explorer"
>>>>>> KeyMachinePoliciesExplorer="SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer"
>>>>>>
>>>>>> PNoNetCrawling="Disable Automatically search for network folders and
>>>>>> printers"
>>>>>> ENoNetCrawling="This policy controls whether Windows Explorer (when
>>>>>> Windows Explorer window is open) will periodically search the network
>>>>>> for new shared folders and printers.\n\nIf this policy is Enabled,
>>>>>> Windows Explorer, Tools, Folder Options, View, "Automatically search
>>>>>> for network folders and printers" is not present and Windows Explorer
>>>>>> behaves as there is no check mark (the automatic searching feature is
>>>>>> Off).\n\nIf this policy is Disabled, Windows Explorer, Tools, Folder
>>>>>> Options, View, "Automatically search for network folders and 
>>>>>> printers"
>>>>>> does not display and Windows Explorer behaves as if the check mark is
>>>>>> present (the automatic searching feature is On).\n\nIf this policy is
>>>>>> Not Configured, the Windows Explorer, Tools, Folder Options, View,
>>>>>> "Automatically search for network folders and printers" is displayed
>>>>>> and a user can add or remove the check mark to turn this feature on 
>>>>>> or
>>>>>> off.
>>>>>> VNoNetCrawling="NoNetCrawling"
>>>>>> −− 
>>>>>> Bruce Sanderson  MVP
>>>>>>
>>>>>> It is perfectly useless to know the right answer to the wrong
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>>>>>> question.
>>>>>>
>>>>>>
>>>>>> "Gregg Hill" <bogus@nowhere.com> wrote in message
>>>>>> news:u07yH1Y2EHA.2704@TK2MSFTNGP10.phx.gbl...
>>>>>>> Hello!
>>>>>>>
>>>>>>> Can any of the items in Windows Explorer > Tools > Options > View >
>>>>>>> Advanced Settings be configured via GPO? Specifically, is there any
>>>>>>> way to turn off the "Automatically search for network folders and
>>>>>>> printers" setting for ALL users on an XP SP2 workstation in a 2003
>>>>>>> domain?
>>>>>>>
>>>>>>> This annoying little bugger is a per−user setting and is a pain in
>>>>>>> the
>>>>>>> you know what.
>>>>>>>
>>>>>>> Thank you for helping!
>>>>>>>
>>>>>>> Gregg Hill
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>>
>
>
> 
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