
Re: What do I do to my web site for MAC users be
able to click on

Source:
http://www.tech−archive.net/Archive/Publisher/microsoft.public.publisher.webdesign/2007−09/msg00165.html

From: "DavidF" <Nope@xxxxxxxxxx>• 
Date: Mon, 17 Sep 2007 19:37:03 −0800• 

Devra,

Thanks for the report. Too often I make a best guess at how to fix a
problem, and the OP never reports back as per the final solution. We are all
here to learn, and it is appreciated that you took the time.

I presume that you are still adjusting your layout on a more narrow page
width, as your site shows no change. I really think it is a smart decision.
Read that article about padding that I gave you. It might give you some
ideas about how to use that more narrow page more effectively.

I would also remind you one final time that web media is very different than
print media. The way you approach it, the mindset is entirely different.
Invest some time in learning about the fundamentals of webdesign if you plan
on pursuing this. In fact if you do, I would expect that you quickly move
away from Publisher. You can do a lot with it, but it has way too many
limitations for a professional web designer. Anyway, there is lots of good
information out there just a google away. To get you started, check this out
in all your free time:
http://www.webdesignfromscratch.com/

Good luck to you. Post back when you get the site redesigned. We are looking
forward to a before and after <g>.

DavidF

"Devra" <Devra@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:3E98D9A0−4B73−4CBD−92B4−41F701FB7403@xxxxxxxxxxxxxxxx

I downloaded Firefox like you suggested and took the border off from around
the project on all of the pages and then changed my background to white.
I
hadn't used a Master Page so didn't have to do anything with that. I had
already ran the Design Checker before and fixed everything it brought up.
I
thought about changing the width but decided against it but after Mike
made
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the comment about it today I did make it narrower per your and his
suggestion.

You had suggested changing the font but it showed that it was a Web font
so
I didn't change it. I haven't checked the website on another computer but
if
it shows up as a font I don't like then I'll change the font. Papyrus is
the
font they have on all of their stationery, that's why I used it.

Thanks again for your help. I hope that someone else gets some use out of
this also.

Devra

It DOES work on the Mac's and they're very happy now!!!

"DavidF" wrote:

Devra,

Thanks for posting back. I see the links do work now in FF. Are you
saying
that they also work on a MAC now?

Would you please share with us which of the many different possible fixes
I
proposed actually did fix the problem with the links? It would be
appreciated.

DavidF

"Devra" <Devra@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:2A181391−6FF1−4A25−9EE7−9AC6491D72B6@xxxxxxxxxxxxxxxx

David,

Just wanted to let you know that all of your efforts into
helping me
have
paid off! I had it done by noon yesterday but was waiting for
the
owner
of
the website to make sure it worked correctly and it did!!!!

Your instructions were very simple and concise and I
appreciate your
help
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immensely!

Thank You Again!!!
Devra
"DavidF" wrote:

Devra,

By the way, I didn't read your original post
very well. You did say
that
you
were using Pub 2007 and I just didn't notice.
I tend to assume people
are
using 2003 and thus the directions about
VML...sorry.

You have fallen into the common trap of
using print document
formatting,
fonts, and design techniques. Web pages are
a different medium, and
you
can't convert everything you do on a print
document to html. You have
to
change your mindset.

This is probably why the hyperlinks do not
work on an MAC, or in
FireFox
as
Mike points out. Everything including the
links are converted to
images
in
FF, and this kills the links.

You should design and test your Publisher
webpages so that they work
in
both
IE and in FF. If you accomplish that goal,
then I would bet that your
MAC
friends will also find the links work.

The first thing you should do is download
and install FireFox.
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http://en.www.mozilla.com/en/firefox/
It is a relatively small file size and a quick
download...and is free.
Then
you can install it, but opt out of making it the
default browser, so
you
can
still use IE as the default.

Then when you want to test your Pub
webpages in FF, just Publish to
the
Web
and direct the html output, the index.htm file
and the index_files
folder,
to your computer where you can easily find
them. I use a folder on the
Desktop. Then open FireFox and go to File
> Open File and browse to
where
you put the index.htm file. This way you can
preview and test the page
before you upload it.

As you now have FF installed and have
produced test files, when you
open
either your internet home page or the test
"index.htm" file of your
web
site
on your computer, try to left click, drag,
select any text on the page
and
you will notice that you can't. It has all been
converted to an image.
And
of course the hyperlinks are dead.

To fix your page so it will work in FF, you
are going to have to
change
some
stuff...and should probably redesign most of
the page. First to the
stuff:

Run the Design Checker in Publisher and see
what it finds are design
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problems. It will likely find most of the
things I noticed, and
perhaps
more.

First of all if you are using a Master Page in
your document, then
don't.
This works fine in a print doc, but not a web
doc. If you were using a
master page and have fixed all the issues
found by the design checker,
then
much of the rest of this reply may not apply.

You probably need to get rid of that green
border. It appears that you
drew
lines around the content and in doing so you
created one big image in
FireFox.
http://www.islandtimerealty.com/index_files/image408.gif
This means everything within it is also
converted to an image and that
the
page is forced to be as long as the image,
even though the page length
isn't
needed. Publisher normally automatically
ends the page after the last
design
element, and thus will produce custom
length pages. In this case, you
end
up
you forcing a 4608 pixel length page...the
length of that border.

Another possible reason for everything being
converted to an image is
that
you have apparently "covered" the
background image that was in the
original
publication. It is in the code, and in the
background, but it does not
show
on your page. Here is the background image:
http://www.islandtimerealty.com/index_files/image321.gif

Here is the image that you "covered" the
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background with:
http://www.islandtimerealty.com/index_files/image809.gif
This is a white colored image that is 1344 X
4608! I am not sure how
you
did
this, but if you added the image to cover the
background or a white
filled
text box, that was the wrong approach. If
you want a solid white
background
on your web pages go to Format >
Background. Under Apply a background
select
the white color. That will replace
image321.gif as the background
image,
and
you will not need the white image or text
box you added to the Pub
document
as a background. Fix this and you may fix
the page length problem and
everything turning into an image when you
create the html.

The next problem to fix is the fonts you have
chosen to use. Papyrus
is
not
a web friendly font, and as a result Publisher
converts it to an
image,
and
kills the links. Change your nav bar button
fonts to a web friendly
font.
Select the text, go to Format > Font and in
the dialog make sure that
Show
only Web fonts are selected. Choose one of
those. Test to see if this
alone
will fix the problem of killing the link in FF.
You may also have to
remove
the border on those text boxes. If you prefer
to use a non−web
friendly
font
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in a title or some other way, then might be
ok if you are ok with it
being
an image. However, that text will probably
look a little fuzzy as an
image...and of course the search engine
robots won't be able to index
your
page cuz they don't read images...your
choice.

Now those are just the problems I caught on
your home page...there may
be
more. Remember some things you do in
print, just won't convert to
html.
Here
is a good reference and though it is talking
about formatting an email
message in html, many if not most of the
formatting issues it
discusses
also
apply to web pages. So you can use this list
to help you troubleshoot
any
other issues you have on your page(s).
Reference: Tips and
troubleshooting
for sending a publication page as an e−mail
message:
http://office.microsoft.com/en−us/publisher/HP010390591033.aspx?pid=CH062524821033

Now I also asserted that it would probably
be a good idea to do a
complete
redesign. As you will already be making a
lot of changes that will
probably
require you to change your layout, I would
suggest that you reconsider
your
page width. If you purposely chose to make
your page 1344 +/− pixels
wide,
then in my opinion that is a major mistake.
That is way too wide.

If you go to Edit > Page Setup you will
notice that you have three
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default
web page widths of 600, 760 and new to Pub
2007, 984 pixel wide pages.
And
if you see these measurements in inches then
back up a step and go to
Tools
Options and on the General Tab change the
Measurement units to pixels
from
inches. It is much better to design a web
page using pixels rather
than
inches. But I digress...there are reasons the
widest default page
width
is
only 984 pixels wide. The primary one being
that pages wider than that
are
going to require horizontal scrolling on way
too many users'
computers.
Yes,
monitors are coming bigger and bigger, but
think about the 14" and 15"
screen laptop users. Chances are they are
going to have to scroll
sideways
to read your page, and guess what...they
won't. They will leave the
page
rather than deal with the hassle.

With this said, though you can probably
make your pages work at their
current width in FF and thus on MACs, since
you are already
redesigning
and
redoing much of the page anyway, I would
suggest that you also change
the
width of your page to either 760 pixels wide
or at most the 984 pixels
and
change your layout to fit that width. The
people that view the page
will
thank you.
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As you redesign, you should also read this:
Understanding background
padding
in a Publisher web (aka white space) :
http://msmvps.com/blogs/dbartosik/archive/2006/01/07/80563.aspx
Until we figure out a way to do it with code,
the best you can do is
simulate centering your web page in 2007.

OK, now that I have written a small book, I
will turn it over to you.
I
know
I have suggested a lot of work, but if you
want a functional web site,
you
will have to make changes. Work through
what you can, and if you need
more
help please post back with the specific
problem and the URL pointing
to
it,
and we will try to help more.

Good luck.

DavidF

"Devra"
<Devra@xxxxxxxxxxxxxxxxxxxxxxxxx>
wrote in message
news:D95F974B−A43B−4240−A841−B2C9472D1C90@xxxxxxxxxxxxxxxx

David,

I didn't use a normal
navigation bar, I just put a
box and typed the
page
names inside the box and
created links to the other
pages and also
links
within the pages to either
e−mail or take them to
another page on
the
site.
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The website is:
www.islandtimerealty.com

Thanks for your help!
Devra

"DavidF" wrote:

Ok...you
didn't
specify
which
version of
Publisher
you were
using
and
the
"rely on
vml..."
option was
removed in
Pub 2007.

Please post
the URL of
the website,
and we
might be
able to help
you
further.

Chances are
the navbar
is being
turned into
an image by
the browser
that
doesn't
work. This
kills the
links. If you
are per
chance
putting
the
navbar
on a master
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page, that
would also
mess things
up...don't
use a
master
page
with
Publisher
web pages.

What you
might have
to do is
build a
textual
menu and
place it on
your
site,
perhaps at
the bottom
that will
work in all
browsers...will
explain
further
after
viewing
your site.

DavidF

"Devra"
<Devra@xxxxxxxxxxxxxxxxxxxxxxxxx>
wrote in
message
news:D51F97C5−F8FB−4410−B4D4−E004B356F95B@xxxxxxxxxxxxxxxx

I
have
Publisher
2007.
When
I
go
to
"tools"
and
then
"options"
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and
then
the
"web
tab"
the
box
to
"allow
png....."
is
already
unchecked
and
there
is
nothing
that
says
anything
about
"rely
on
VML....."

The
only
problems
that
I
am
aware
of
is
they
can't
click
on
ANY
links,
thus
not
being
able
to
navigate
through
the
website.
It's
as
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if
there
are
no
links
made,
but
I
have
checked
on
3
computers
(not
MAC)
that
it
works
fine
on.

Any
other
suggestions?

Devra

"DavidF"
wrote:

Have
them
buy
a
PC.
<g>

Getting
full
cross
browser
compatibility
is
a
challenge
with
any
program
you
use
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to
build
a
web
site.
In
most
cases
you
can
work
through
some
of
the

.
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