Re: >NET Compact framework 2.0 application is not running



Are you possibly not using the new nk.bin registry and using some other,
left-over from previous builds registry on the device? You might also
verify, using Remote Registry Editor, that the device registry matches the
entries found in the .NET CF source directory. I don't have CE6 in front of
me, but, in CE5, it's \public\netcfv2\oak\files\netcfv2.reg.

Are secur32.dll, ole32.dll, oleaut32.dll, and ws2.dll in your OS?

Are you building a headless device or one with a display? If you have a
display, is commctrl.dll in your image?

Maybe there's a problem with the dependency processing and something that is
required is not being pulled in automatically...

Paul T.

"Vinoth" <vinoth@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:07D288D1-F94F-4C79-BEEF-B13E6A79DC07@xxxxxxxxxxxxxxxx
Thank you for your reply. I tried to run the cgacutil.exe in the device
console. but i fails to run after giving the message "Registration
Failed".

I run the C# application on the device directly. It is just an Smart
device
windows CE hello world project. I checked this application with other
platform. it is working.
Thanks,
--
vinoth.

"Bruce Eitman [eMVP]" wrote:

How are you trying to run it?

--
Bruce Eitman (eMVP)
Senior Engineer
Bruce.Eitman AT EuroTech DOT com
My BLOG http://geekswithblogs.net/bruceeitman

EuroTech Inc.
www.EuroTech.com

"Vinoth" <vinoth@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:17CF261B-95AD-4079-AFB2-4BE77788AD30@xxxxxxxxxxxxxxxx
Hi,
I am working on PXA320 based platform. windows CE 6.0 is running on
this.
I
tried to run a simple C# application created using the VS2005 but it is
not
running. i haven't get any error messages even in the debug build. I
have
added the .Net Compact framework 2.0 and its OS dependencies through
the
Catalog items (SYSGEN_DOTNETV2 and SYSGEN_DOTNETV2_SUPPORT).
All the related DLLs are added in the ce.bib file. i found the
cgacutil.exe
in the Windows Directory of the device ( i have seen the info in some
other
thread).
But still the application is not running.

I tried the same pbxml file with different BSP ( PXA320 based BSP). It
is
working on that BSP. I am afraid, is there any dependencies in BSP for
the
.NET Compact frame work? if yes Please let me know the dependence.

i found an info regarding the changes in the CEProcessorType variable
from
PROCESSOR_STRONGARM to PROCESSOR_ARM920. eventhough i changed the
processor
type, the .net application is not running on my device.

Please advise me,
Thanks & Regards,
--
vinoth





.