CE5 Slow boot from CF but fast when downloaded



My project is a simple CEPC with most options taken out. The release nk.bin
comprises less than 11MB. When the target is connected to Platform Builder
via Ethernet, the image downloads in 9 seconds and comes alive 6 seconds
after this. When I put the same nk.bin on a Compact Flash card that boots DOS
in the target and uses the same loadcepc program to load this local nk.bin, I
see six seconds of "Section physical start" console messages and then nothing
for 90 seconds, when the CE OS finally comes to life. Serial debug output
shows a few initial messages but nothing during the 90 seconds. What could be
happening during this time?
.



Relevant Pages

  • PB Cant Communicate With Device After EBOOT in CE 5.0
    ... Windows CE Desktop appears on the target, Platform Builder can no longer ... I am using Platform Builder for Microsoft Windows CE 5.0, ... The Kernel Debugger is waiting to connect with target. ...
    (microsoft.public.windowsce.platbuilder)
  • Re: how can i make use of eVC++ for developing applications
    ... OS is built or you can just leave PB running while you play with eVC. ... KITL and the kernel debugger on. ... my application need the Platform builder to activate. ... Actually, when I built the OS image for the target board, I had encounter ...
    (microsoft.public.windowsce.embedded.vc)
  • Re: Error Invalid Signature
    ... "jumping to 0x0013603c" on the target in response to: ... the platform builder is set up to download to the target via the ... "B000FF" signature. ...
    (microsoft.public.windowsce.platbuilder)
  • reconnecting a CEPC or Geode to platform builder without re-booting
    ... We have been rebooting the target everytime we needed to restart debugging ... After getting Activesync running for the application debugging, ... set to use it to connect to the Platform Builder and get rid of the boot to ... ethernet download doesn't begin until the target sends a BOOTME. ...
    (microsoft.public.windowsce.platbuilder)