Re: OpenNetCf dlls



Thank you for your reply.

It's a new project, new Os. I don't use anymore Compact framework 1.0 and
OpenNetCF1.4.

I put all the OpenNetCf DLLs in the Bib file of the project (15 DLLs.),
Compact framework 2.0 is included in the OS. I don't get what I forget.

Nat.

"Chris Tacke, eMVP" wrote:

Well, from what we know all we can deduce is that either you're missing a
file or you have a wrong version deployed. If you only deployed one of the
2.x DLLs and you still have some 1.4 versions there, you're going to have
problems.


--

Chris Tacke, Embedded MVP
OpenNETCF Consulting
Giving back to the embedded community
http://community.OpenNETCF.com


"Nat" <Nat@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:A3B3EEE0-F4D3-4037-8FA4-3C9EF3E7BCFF@xxxxxxxxxxxxxxxx
Thank you for your reply
I put them in the FILES section of my BIB file.
Actually It was working with the previous version of OpenNetCf 1.4. I did
the same kind of thing with 2.2 version and it doen't work. That 's why I
don't catch my mistake.

Nat.

"Paul G. Tobey [eMVP]" wrote:

Where did you put it? Remember that it's a managed code DLL, not a
native
DLL. It can't be in the MODULES section of your BIB file...

Paul T.

"Nat" <Nat@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:00328120-9720-488B-B202-9F91954AB246@xxxxxxxxxxxxxxxx
For my smartdevice application, I use the OpenNETCF.Windows.Forms.dll.
So
i
added the DLL to the OS. But when I run the application, I get an
exception
"MissingMethodException": File or Assembly name
"OpenNETCF.Windows.Forms"
or
one of its dependencies was not found.

Then I put all the OpenNetCF dlls in my OS, but I still get the same
Exception.

I don't get my mistake. Any idea?

Nat.








.