Re: Clone SkinnableUI



The skinnable ui is a special case. If you take a look at the master makefile in \PUBLIC\COMMON\CESYSGEN and search for gcacheviewxp then you'll find that all you need to do is to copy the gcacheviewxp folder (or anything you want to modify) add the resource file to the list of sources, add RELEASETYPE=LOCAL set the WINCETARGETFILES to just $(TARGETNAME).res and build the lib. Then make sure you set GWES_REPLACE=1 in your OSDesign and modify the makefile.inc to copy the lib and res files to a special folder and set REPLACE_ROOT to this folder (libs and res need to be in oak\lib\$(_CPUINDPATH) and oak\lib\$(_CPUINDPATH)\$(CURRENT_LANGID), see the master makefile.

You can skip the setting of REPLACE_ROOT and just create a lib\$(_CPUINDPATH) in your _PROJECTROOT). Then all you need to do is set RELEASETYPE=OAK and change the makefile.inc to copy the res to $(_PROJECTROOT)\oak\lib\$(_CPUINDPATH)\0409\$(TARGETNAME).res (replace the langid with the one needed).

Note that I didn't try anything out, I'm just reading and translating the makefile into instructions. Maybe you need to do something more, but you'll figure it out by looking at the master makefile.


Good luck,

Michel Verhagen, eMVP
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

lsimoni wrote:
So, I'm trying to clone a catalog item, specifically the SkinnableUI. There are documents on MSDN that show how to clone by right clicking on a catalog item, and Michel has a great post on how to clone items that don't have that option (netui):

http://www.guruce.com/blogpost/cloningpubliccodeanexample

But I'm trying to clone the SkinnableUI component and it doesn't fit any documentation I"ve found so far. There must be an easy way to do this, I'm sure I'm just missing something.

When I follow Michel's blog and use the sysgen_capture -p common skinnableui, it returns an error. If I try and copy a single component from the skinnableui folder, like gcacheview and run the sysgen_capture -p gcacheview, I get an error saying:
BUILD: [01:0000000028:ERRORE] NMAKE : U1073: don't know how to make 'gcacheviewxp.def'
BUILD: [01:0000000029:INFO ] Stop.
BUILD: [01:0000000030:ERRORE] NMAKE.EXE TargetExeFiles -i -c BUILDMSG=Stop. BUILDROOT=C:\WINCE600\OSDesigns\OSDesign2\OSDesign2\GCACHEVIEWXP\ LINKONLY=1 NOPASS0=1MAKEDLL=1 failed - rc = 2

Sorry if I'm asking the obvious, but I'm lost here. From everything I've read, this should be so simple, and yet I can't get it to work.
.