Re: Build and Sysgen question



Include DSHOW components. Make sure you set the "clean before building" flag is on... Do a build and sysgen...and then...

Happy reinstalling PB(I tested this one month ago)!

Installing QFE's *might* update the libs you need but doesn't necessarily.

Besides the fact that it isn't necessary (because everything is there in binary from), the build process takes a lot of time.

Anyhow, look at the many post about this,

Good luck,

Erwin Zwart,
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

Joe Welfeld schreef:
Hi All,

I have been working in the embedded world for many years, but relatively new to WinCE (5.0 for less then 2 years). I use this newsgroup religiously (It seems I am the only one here that uses it ). I read and have adhered to the Never Ever do a build and Sysgen, but I just got into a discussion with someone who does them all the time and doesn't see any problem. My understanding of the problem is that if I do a Clean with "build and sysgen" I cannot re-build all the lib's as delivered by Microsoft. I guess I cannot argue this point persuasively enough and was wondering if someone can point me to real examples of what lib's I cannot rebuild because I don't have the same code. He mentions that when we install QFE's we get the new lib but I also get the source code that would allow me to create that same lib. If I don't have all the source code then why does a Build and Sysgen with clean actually build my system, one would think we would get link or build errors. So is it possible for someone to list out some of the lib's that I cannot re-build to the same versions as released, otherwise it's a lost argument...

thanks,

Joe W.


.