Re: Build Failed Message



Michel,

Again, many thanks for your help. Once I installed the CF 2.0, I was able
to debug in VB again. I couldn't install the CF 3.5 because I'm running
win2k. I can't do a clean install because I've got so many other dev tools
that are already configured. It would take a week to reinstall everything -
I typically design in assembly language for Freescale microcontrollers.

At least I can generate a CE image and debug my VB application. This will
get me through for now. We are in the process of moving to a bigger facility
and expect to move within the next month or so. When we do, I'll be getting
a newer machine that will hopefully work with a clean install of everything.

Thanks again for all of your help, you've gotten me to the point where I can
continue with development on this project.

Sincerely,
Lucio

"Michel Verhagen (eMVP)" wrote:

Try this
http://www.microsoft.com/downloads/info.aspx?na=22&p=4&SrcDisplayLang=en&SrcCategoryId=&SrcFamilyId=&u=%2fdownloads%2fdetails.aspx%3fFamilyID%3daea55f2f-07b5-4a8c-8a44-b4e1b196d5c0%26DisplayLang%3den

and this
http://www.microsoft.com/downloads/info.aspx?na=22&p=2&SrcDisplayLang=en&SrcCategoryId=&SrcFamilyId=&u=%2fdownloads%2fdetails.aspx%3fFamilyID%3de3821449-3c6b-42f1-9fd9-0041345b3385%26DisplayLang%3den

But seriously, do a complete re-install of your machine, or buy VMWARE.


Good luck,

Michel Verhagen, eMVP
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

lsimoni wrote:
To answer your question, no. I can't build any driver or subset of the OS by
right clicking and selecting build.

But wait, it gets better! I thought I was safe to move on and work on my VB
application since I was able to build and run the 6.0 OS. So, I switched
over and tried to load my VB project, and I get an error saying that it can't
load the project because mscorlib.dll is missing... I searched on my other
development computer and found it here: \\Engspare\c\Program Files\Microsoft
Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE. So, I
look on my computer and I don't even have the CompactFramework directory
present, even after reinstalling EVERYTHING from VS to all the QFE's for 6.0!


I even did a re-install of the .net framework 2.0 SDK.

It may definitely be time for a new PC.


"Michel Verhagen (eMVP)" wrote:

Wow, that's strange. All the IDE does is execute the command line
version of the build system...

What happens if you do a targeted-build of for instance your BSP or a
driver inside the BSP? You do a targeted build from the IDE by right
clicking the item in the workspace and choose "Build".

I think you may want to open a support case with Microsoft on this. You
get 2 free support calls with Platform Builder, so it won't cost you
anything (but you may need your 2 free calls for "real" later).

The obvious solution to your problem is a reinstall of the entire
machine (and this may be cheaper to you than spending a free support
call), because there is still something wrong with your installation.

I use VMWARE for all my Windows CE work (because I still use CE 3.0,
4.2, 5.0, 6.0 & Windows Mobile and they don't install side-by-side).
Maybe VMWARE is another solution for your problem (since you will be
installing on a clean XP installation).


Good luck,

Michel Verhagen, eMVP
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

lsimoni wrote:
Michel,

OK, I'm back up and running now. Everything is reinstalled, even the QFE's
(your installer program is amazing).

When I started VS for the first time, I selected the Platform builder
configuration (previously I was using the Visual Basic screen Configuration),
now I have an output window at the bottom of the screen showing the build
output data. I get different errors depending on which build function I do:

Build Solution:
Error: Value cannot be null.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

Build Osdesign1:
Error: Value cannot be null.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

Sysgen:
Error: Exception has been thrown by the target of an invocation.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

I received no build.log file in the C:\WINCE600 folder.

I then opened a command prompt using "open release directory in build
window" from the build menu and used the "blddemo -q" command and the build
runs just fine in the command prompt. 29 minutes later I have a build OS,
complete with Build.log file in the WINCE6000 folder. I can run/debug the OS
just fine.

Am I stuck using the command promt for building?

Also,
Thanks for the help and utilities so far. I really appreciate it.

Lucio

"Michel Verhagen (eMVP)" wrote:

Ok, first of all, you were talking about long build times. This
indicates to me you may be building the wrong things (maybe you even did
a build & sysgen?!). Please read this:
http://guruce.com/blogpost/whattobuildwhen

If you did a build & sysgen you've destroyed your build tree and that
could result in build errors. A reinstall should however completely
solve that issue.

Stupid (?) question: How much space do you have left on the disk after
the installation?

In your case I would de-install (don't forget to first deinstall any
service packs), then manually delete the C:\WINCE600 folder, also
uninstall any VS2005 SP's and VS2005 itself, and delete any of the
folders under \Program Files\ belonging to VS2005, then open regedit and
search for "Windows CE", "Platform Builder" and "Visual Studio" and
delete all those keys.

Then do a reinstall following this exact order:

1. Visual Studio 2005
2. MSDN Library
3. Windows CE 6.0 Platform Builder
4. Visual Studio 2005 Service Pack 1
5. Windows CE 6.0 Platform Builder Service Pack 1
6. Windows CE 6.0 R2 (see also
http://guruce.com/blogpost/offlineinstallationofthece60r2update)
7. Windows CE 6.0 USB Camera Driver (if you want)
8. Download and install all QFE's for Windows CE 6.0 (see also
http://guruce.com/blogpost/downloadqfes and use the QFEInstaller from my
webpage to save you a million clicks)

If it still doesn't work after following these steps then throw the PC
out the window, change jobs, wife, country and name and never think
about Windows CE ever again. (Been there, not done it yet...)


Good luck,

Michel Verhagen, eMVP
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

lsimoni wrote:
I finally got everything re-installed and up and running again. First of
all, yes I'm an administrative user. Also, I navigated to the gwexp driver
and ran the 'build -c' command and it worked just fine. I even get a
build.log in that folder when the build is complete. I tried again in the
IDE, and I get the same build failed message.

"Paul G. Tobey [eMVP]" wrote:

You did a search in \wince600 for *.log? You are an administrative user?
If you open a build window in the release folder of your project and
navigate to some driver under your BSP/platform folder, can you do a
'build -c' there and have it work? It sounds like sysgen is failing, maybe.

Paul T.

"lsimoni" <lsimoni@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:FEC75923-9833-48A1-839C-ACAF1C9605BB@xxxxxxxxxxxxxxxx
I only wish that was the problem, I used the default options for
installation. I even used names like osdesign1 to ensure there were no
spaces. Still no go.

"Paul G. Tobey [eMVP]" wrote:

You don't have any long path names in where you installed Windows CE 6,
do
you? You didn't change the default, c:\wince600, to something like c:\my
projects\Windows CE\wince600? Paths with spaces in them are notorious
for
causing serious build failures. I'm surprised there's no file build.log
anywhere in the \wince600 folder, though. Are you sure?

Paul T.

"lsimoni" <lsimoni@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:FCEE966D-6F9A-4F91-91DA-184212393B3A@xxxxxxxxxxxxxxxx
I just installed it, the time doesn't run out for a couple of months
still.
I don't even get any error messages. Just the Build Failed status at
the
bottom left corner of the IDE.

We would buy CE, but I'm supposed to be evaluating whether we should be
using XPe or CE. So I'm trying both to see which would work better for
us.

"Ravi" wrote:

Well usually the evaluation version comes with a time limit. If you
have
exceed this time limit you will get a error with the phrase "time
bomb".
If
that is the case then the solution is simple, its time to buy the CE
6.0
:)

HTH
Ravi

"lsimoni" wrote:

I've been using the evaluation version of CE 6.0 for several weeks
now
without issues. Now all of a sudden I'm getting a "build failed"
message on
the status bar at the bottom of the screen immediately after I try
any
of the
build commands (build, rebuild, sysgen, etc). There are no errors,
no
warnings, and no .txt logs generated in the WINCE600 directory.
I've
tried
re-installing, but it doesn't fix the problem.

I've tried new projects for different targets, but every time I try
to
build
the status goes directly from build started to build failed.

.



Relevant Pages

  • Re: Build Failed Message
    ... But seriously, do a complete re-install of your machine, or buy VMWARE. ... because there is still something wrong with your installation. ... I received no build.log file in the C:\WINCE600 folder. ... Windows CE 6.0 Platform Builder ...
    (microsoft.public.windowsce.platbuilder)
  • Re: Build Failed Message
    ... you should (take a look at my blog for more info on cloning). ... The obvious solution to your problem is a reinstall of the entire machine, because there is still something wrong with your installation. ... I received no build.log file in the C:\WINCE600 folder. ... Windows CE 6.0 Platform Builder ...
    (microsoft.public.windowsce.platbuilder)
  • Re: Windows XP & new motherboard
    ... But Windows 2000 and XP mostly just ... > buy or borrow a true installation XP CD. ... > some of the apps that came with the system. ... > 4) Enter "cd olddrive" to switch to the new folder ...
    (microsoft.public.windowsxp.general)
  • Re: Build Failed Message
    ... I can't build any driver or subset of the OS by ... because there is still something wrong with your installation. ... I received no build.log file in the C:\WINCE600 folder. ... Windows CE 6.0 Platform Builder ...
    (microsoft.public.windowsce.platbuilder)
  • Re: Users all mixed up after reinstall: How to clean up?
    ... It appears that your original installation was an upgrade from Windows 98. ... That's why you have a Windows system folder and all the new users had some sort ... log on as Administrator then go to Control Panel> Users ...
    (microsoft.public.win2000.general)