Re: Build Failed Message



Michel,

I'm sure I've done a build & sysgen at some point in time... (I've got the
philosophy of "if one button doesn't work, click another").

I've got about 25Gigs free on a 120 gig drive.

When I've reinstalled, I didn't uninstall, I did the reinstall option from
the add/remove programs and definitely didn't delete the wince600 folder or
registry keys.

Thanks for the whattobuildwhen link. Definitely informative. They put the
menu options in Visual studio, but don't tell you what they actually do!
Very dangerous for us newbie click happy developers...

Also, thanks for the straightforward instructions. It will probably take
all day to uninstall and re-install, but I'm hoping it will work.

"Michel Verhagen (eMVP)" wrote:

Ok, first of all, you were talking about long build times. This
indicates to me you may be building the wrong things (maybe you even did
a build & sysgen?!). Please read this:
http://guruce.com/blogpost/whattobuildwhen

If you did a build & sysgen you've destroyed your build tree and that
could result in build errors. A reinstall should however completely
solve that issue.

Stupid (?) question: How much space do you have left on the disk after
the installation?

In your case I would de-install (don't forget to first deinstall any
service packs), then manually delete the C:\WINCE600 folder, also
uninstall any VS2005 SP's and VS2005 itself, and delete any of the
folders under \Program Files\ belonging to VS2005, then open regedit and
search for "Windows CE", "Platform Builder" and "Visual Studio" and
delete all those keys.

Then do a reinstall following this exact order:

1. Visual Studio 2005
2. MSDN Library
3. Windows CE 6.0 Platform Builder
4. Visual Studio 2005 Service Pack 1
5. Windows CE 6.0 Platform Builder Service Pack 1
6. Windows CE 6.0 R2 (see also
http://guruce.com/blogpost/offlineinstallationofthece60r2update)
7. Windows CE 6.0 USB Camera Driver (if you want)
8. Download and install all QFE's for Windows CE 6.0 (see also
http://guruce.com/blogpost/downloadqfes and use the QFEInstaller from my
webpage to save you a million clicks)

If it still doesn't work after following these steps then throw the PC
out the window, change jobs, wife, country and name and never think
about Windows CE ever again. (Been there, not done it yet...)


Good luck,

Michel Verhagen, eMVP
Check out my blog: http://GuruCE.com/blog

GuruCE
Microsoft Embedded Partner
http://GuruCE.com
Consultancy, training and development services.

lsimoni wrote:
I finally got everything re-installed and up and running again. First of
all, yes I'm an administrative user. Also, I navigated to the gwexp driver
and ran the 'build -c' command and it worked just fine. I even get a
build.log in that folder when the build is complete. I tried again in the
IDE, and I get the same build failed message.

"Paul G. Tobey [eMVP]" wrote:

You did a search in \wince600 for *.log? You are an administrative user?
If you open a build window in the release folder of your project and
navigate to some driver under your BSP/platform folder, can you do a
'build -c' there and have it work? It sounds like sysgen is failing, maybe.

Paul T.

"lsimoni" <lsimoni@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:FEC75923-9833-48A1-839C-ACAF1C9605BB@xxxxxxxxxxxxxxxx
I only wish that was the problem, I used the default options for
installation. I even used names like osdesign1 to ensure there were no
spaces. Still no go.

"Paul G. Tobey [eMVP]" wrote:

You don't have any long path names in where you installed Windows CE 6,
do
you? You didn't change the default, c:\wince600, to something like c:\my
projects\Windows CE\wince600? Paths with spaces in them are notorious
for
causing serious build failures. I'm surprised there's no file build.log
anywhere in the \wince600 folder, though. Are you sure?

Paul T.

"lsimoni" <lsimoni@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:FCEE966D-6F9A-4F91-91DA-184212393B3A@xxxxxxxxxxxxxxxx
I just installed it, the time doesn't run out for a couple of months
still.
I don't even get any error messages. Just the Build Failed status at
the
bottom left corner of the IDE.

We would buy CE, but I'm supposed to be evaluating whether we should be
using XPe or CE. So I'm trying both to see which would work better for
us.

"Ravi" wrote:

Well usually the evaluation version comes with a time limit. If you
have
exceed this time limit you will get a error with the phrase "time
bomb".
If
that is the case then the solution is simple, its time to buy the CE
6.0
:)

HTH
Ravi

"lsimoni" wrote:

I've been using the evaluation version of CE 6.0 for several weeks
now
without issues. Now all of a sudden I'm getting a "build failed"
message on
the status bar at the bottom of the screen immediately after I try
any
of the
build commands (build, rebuild, sysgen, etc). There are no errors,
no
warnings, and no .txt logs generated in the WINCE600 directory.
I've
tried
re-installing, but it doesn't fix the problem.

I've tried new projects for different targets, but every time I try
to
build
the status goes directly from build started to build failed.





.