Re: Can't see performance report, etc. SBS2003



Hi Terence,
Thx for your reply. I'll be out of the office for about a week or so. I'll
try your suggestions when I return & post the results and/or email you then.
Again, thx,
D

"Terence Liu [MSFT]" <v-terliu@xxxxxxxxxxxxxxxxxxxx> wrote in message
news:2s6uIZfxIHA.3644@xxxxxxxxxxxxxxxxxxxxxxxxx
Hello Dana,

Thank you for your update.

I'm glad you find the root cause of the default web site issue.

Per my research, on pre-SP2 Win2003 systems when we create a log file
(collection) that has a scheduled start and stop time it changes the
startup type of the "Performance Logs and Alerts" service (SysmonLog) to
"Automatic". Even though the startup type is changed to "Automatic" the
service only runs when at least one collection is scheduled.

After I discussed with MSDN, the SysmonLog service starts and stops each
named performance data collection based on the information that is
contained in the named log collection setting. In other words, collecting
the actual data for the performance log is controlled by starting and
stopping the service. Windows Performance monitor component changes the
startup type to "Automatic" to ensure that the scheduled log would
continue
even if the server rebooted unexpectedly. MSDN also states that changing
the startup type to "Automatic" is done to allow data to be logged and
alerts to be generated without an administrator being logged on. Either
way, prior to SP2, the startup type is only changed back to "Manual" when
all of the scheduled collections are deleted.
This change was made to ensure that scheduled logs and alerts are properly
restarted following a system reboot. As before, the service will only run
if at least one collection is scheduled. Other than adding a quick check
on
system boot, changing the default startup type should not have any impact
on the behavior of the service.

In SBS, when system collect the log, this service will shut down itself
when in leisure time. So you will the event AUTO -STARTED SERVICES NOT
RUNNING error.

http://technet2.microsoft.com/WindowsServer/en/library/ed5382af-e819-4d33-ac
e0-225d31b7ab751033.mspx?mfr=true

Therefore you can ignore the warning about "Performance Logs and Alerts".
However, for "OpenSSH Server", you need to ensure it started, or set
startup type to "Manual".

For event error 4096 and 4097, I suggest you perform clean boot on SBS to
isolate this issue:

To clean boot the problematic computer, please use the steps below:
a. Click Start, click Run, and then in the Open box, type "MSCONFIG"
(without the quotation marks). Click OK.

b. In the System Configuration Utility (MSConfig) window, click to select
the Selective Startup button.

c. Click to clear the check mark from the "Load startup items" below
Selective Startup.

d. Click the Services tab, click to check the "Hide All Microsoft
Services"
box, and remove all the check marks from the remained Non-Microsoft
Services. Please note that the Exchange services could be marked as
non-Microsoft. Please do not disable those services.

e. Click OK to close the MSConfig window. Click Yes when you are asked to
restart your computer in order to enable the changes.

f. After restarting, please check whether this issue will reoccur.

g. If there are no more problems, please use the above steps to enable
services and startup items one by one in order to figure out the root
cause
of this issue.

If we cannot resolve the issue after we perform the above steps, please
help me collect some information for further investigation:

1. Please save the report email to msg file and send to me.

2. Gather MPS network report on SBS:

a. Download MPSrepot_network from
http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
15706/MPSRPT_NETWORK.EXE

b. Run MPSRPT_NETWORK.exe.

c. The tool will automatically collect the information. This procedure
will
take 10~15 minutes.

d. Open Windows Explorer, navigate to the folder:
%SystemRoot%\MPSReports\Network\Reports\Cab\

e. Send the .cab file directly to me at v-terliu@xxxxxxxxxxxxx

I hope these steps will give you some help.

Thanks and have a nice day!

Best regards,

Terence Liu (MSFT)

Microsoft CSS Online Newsgroup Support

Get Secure! - www.microsoft.com/security

=====================================================
This newsgroup only focuses on SBS technical issues. If you have issues
regarding other Microsoft products, you'd better post in the corresponding
newsgroups so that they can be resolved in an efficient and timely manner.
You can locate the newsgroup here:
http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

When opening a new thread via the web interface, we recommend you check
the
"Notify me of replies" box to receive e-mail notifications when there are
any updates in your thread. When responding to posts via your newsreader,
please "Reply to Group" so that others may learn and benefit from your
issue.

Microsoft engineers can only focus on one issue per thread. Although we
provide other information for your reference, we recommend you post
different incidents in different threads to keep the thread clean. In
doing
so, it will ensure your issues are resolved in a timely manner.

For urgent issues, you may want to contact Microsoft CSS directly. Please
check http://support.microsoft.com for regional support phone numbers.

Any input or comments in this thread are highly appreciated.
=====================================================

This posting is provided "AS IS" with no warranties, and confers no
rights.

--------------------
From: "Dana" <nospam@xxxxxxx>
References: <#X0M3REwIHA.3380@xxxxxxxxxxxxxxxxxxxx>
<XGc40zWwIHA.5796@xxxxxxxxxxxxxxxxxxxxxx>
Subject: Re: Can't see performance report, etc. SBS2003
Date: Tue, 3 Jun 2008 17:26:02 -0400
Lines: 318
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
Message-ID: <#BwI2BcxIHA.4560@xxxxxxxxxxxxxxxxxxxx>
Newsgroups: microsoft.public.windows.server.sbs
NNTP-Posting-Host: 204.60.94.234
Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP03.phx.gbl
Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.server.sbs:110562
X-Tomcat-NG: microsoft.public.windows.server.sbs

Thanks everybody for the replies. Here's the story, please bear with me
as
I'm not a tech person:
When you install Symantec EP it adds Symantec to the web-sites in IIS. So
when we went to IIS mgr the default website was stopped. When we tried to
start it it couldn't start because another site was using the same port.
That site was Symantec & the port is 80. So, we called Symantec and they
basically had us change the port to 81 (for the Symantec Site). This was
a
bit of a PIA & certainly not intuitive but I will say they were pretty
good.
That seemed to solve our problem. But now in the daily report we get the
following every day (any ideas?):

OpenSSH Server
Performance Logs and Alerts
Total auto-started services not running: 2

In normal conditions, these services should be running. For details,
it is recommended that you review errors in the Event log related to the
service.


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++

We also get these errors from time to time (which we never got b4):

Critical Errors in Application Log


Source Event ID Last Occurrence Total Occurrences
secars 4096 6/2/2008 4:03 AM 1
Create Log File Error!





Source Event ID Last Occurrence Total Occurrences
secars 4097 6/2/2008 4:03 AM 1
Failed to start Radius Server.The radius port may be
used
by another process.


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


I have no idea what any of this means so any help would
be
great.

Thx,

D






"Terence Liu [MSFT]" <v-terliu@xxxxxxxxxxxxxxxxxxxx> wrote in message
news:XGc40zWwIHA.5796@xxxxxxxxxxxxxxxxxxxxxxxxx
Hello Dana,

Thank you for posting here. Let's also thank Cris and Cole for the
input.

According to your description, I understand that the Monitoring &
Reporting in server management does not work and give HTTP 404 error.
If I have misunderstood the problem, please don't hesitate to let me
know.

Based on my research, I suggest we try the following steps to see if we
can resolve this issue:

1. Open services.msc and check if the MSSQL$SBSMONITORING service is
started. If it is stopped, open it, make sure its startup type is
set as "Automatic", go to "Log on" and make sure it is using the "Local
System account". Then start the service and check if everything is
OK.

2. Make sure no host header is assigned to the Default Web Site. When
you
look at the IIS, Default Website, WebSite tab, Advanced. You
should have "Default" as the IP address, 80 and the TCP port, nothing
for
the Host header value. If the settings are not right, correct them
and restart the Default Web Site.

3. Please follow the steps below to check whether the Monitoring Virtual
Directory in IIS is OK.
a. Run inetmgr.
b. Go to Default Web Site/Monitoring.
c. Right click Backup and click Properties.
d. Under "Virtual Directory" tab, you're pointing to C:\Inetpub\
Monitoring. And you're using DefaultAppPool.
e. Under Documents tab, the order of the default content page is
Default.htm; Default.asp; index.htm; iisstart.htm; Default.aspx.
f. Under "Directory Security" tab, click Edit under Authentication and
access control.
g. Make sure that Integrated Windows authentication has been checked.

4. If the issue still occurs, I would suggest you do the following steps
to reinstall the SBS Monitoring component:

Reinstall Monitoring component:
=====================
Note: Please make a full backup of the SBS 2003 server before the
following steps.

I. Uninstall Monitoring

a. Click Start, click Control Panel, and then click Add or Remove
Programs.
b. Select Windows Small Business Server 2003 and then click
Change/Remove. The Setup Wizard appears.
c. Click Next to start the wizard.
d. On the Windows Configuration page, click Next.
e. On the Component Selection page, in the Action column, change
Server Tools to Maintenance, change Monitoring component to
Remove, and then click Next.
f. On the Component Summary page, click Next.
g. Click Finish.

II. Uninstall Microsoft SQL Server Desktop Engine (SBSMONITORING)

In Add or Remove Programs, select Microsoft SQL Server Desktop Engine
(SBSMONITORING) and then click Remove. A dialog box
appears. To confirm that you want to remove, click Yes.

III. Rename the folder

Start Windows Explorer, and then locate and rename the following folder:

C:\Program Files\Microsoft SQL Server\MSSQL$SBSMONITORING

to C:\Program Files\Microsoft SQL Server\Old.MSSQL$SBSMONITORING

IV. Use Registry Editor to delete the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\SmallBusinessServer\Monitoring
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\SBSMonitoring

V. Install the Monitoring component

a. In Add or Remove Programs, select Windows Small Business Server
2003 and then click Change/Remove. The Setup Wizard
appears.
b. Click Next.
c. On the Windows Configuration page, click Next.
d. On the Component Selection page, in the Action column, change
Server Tools to Maintenance, change Monitoring component to
Install, and then click Next.
e. On the Logon Information page, click Next.
f. On the Component Summary page, click Next.
g. Click Finish.

If we cannot resolve the issue after we perform the above steps, please
kindly help me collect some information for further investigation:

1. Please capture screenshots on the Monitoring & Reporting and Backup
info in server management, then send the pictures to me at v-
terliu@xxxxxxxxxxxxx

2. Could uninstall Symantec Endpoint Protection (v11) manager resolve
this
issue?

3. Gather IIS Metabase:

1) Download the IIS Resource Kit tools from the following page:

http://www.microsoft.com/downloads/details.aspx?FamilyId=56FC92EE-A71A-4C73-
B628-ADE629C89499&displaylang=en

2) Install it, run MBExplorer (Metabase Explorer)

3) Right click the "LM" node and choose "Export to file".

4) Specify a file name, specify the password and finish the export.

5) Send the file and the password to v-terliu@xxxxxxxxxxxxx

4. Please send me the Network MPS report.

a. Visit

http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
15706/MPSRPT_NETWORK.EXE.
to download
the file.
b. Run the MPSRPT_NETWORK.EXE on the server box.
c. Wait for 10~15 minutes.
d. Open Windows explorer, navigate to
%SYSTEMROOT%\MPSReports\Network\Reports\cab\
e. Send the .cab file directly to me

Hope these steps will give you some help.

Thanks and have a nice day!

Best regards,

Terence Liu (MSFT)

Microsoft CSS Online Newsgroup Support

Get Secure! - www.microsoft.com/security

=====================================================
This newsgroup only focuses on SBS technical issues. If you have issues
regarding other Microsoft products, you'd better post in the
corresponding newsgroups so that they can be resolved in an efficient
and
timely manner. You can locate the newsgroup here:
http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

When opening a new thread via the web interface, we recommend you check
the "Notify me of replies" box to receive e-mail notifications
when there are any updates in your thread. When responding to posts via
your newsreader, please "Reply to Group" so that others may
learn and benefit from your issue.

Microsoft engineers can only focus on one issue per thread. Although we
provide other information for your reference, we recommend you
post different incidents in different threads to keep the thread clean.
In
doing so, it will ensure your issues are resolved in a timely manner.

For urgent issues, you may want to contact Microsoft CSS directly.
Please
check http://support.microsoft.com for regional support phone
numbers.

Any input or comments in this thread are highly appreciated.
=====================================================

This posting is provided "AS IS" with no warranties, and confers no
rights.

--------------------
| From: "Dana" <nospam@xxxxxxx>
| Subject: Can't see performance report, etc. SBS2003
| Date: Tue, 27 May 2008 17:58:01 -0400
| Lines: 63
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#X0M3REwIHA.3380@xxxxxxxxxxxxxxxxxxxx>
| Newsgroups: microsoft.public.windows.server.sbs
| NNTP-Posting-Host: 204.60.94.234
| Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP03.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.windows.server.sbs:109629
| X-Tomcat-NG: microsoft.public.windows.server.sbs
|
| We're using SBS 2003 std.
|
| On our daily email of the Server Performance report we were getting
the
| following after (I think) installing the new Symantec Endpoint
Protection
| (v11) manager:
|
|
| The page cannot be displayed
| You have attempted to execute a CGI, ISAPI, or other executable
program
from
| a directory that does not allow programs to be executed.
|
| Please try the following:
| Contact the Web site administrator if you believe this directory
should
| allow execute access.
| HTTP Error 403.1 - Forbidden: Execute access is denied.
| Internet Information Services (IIS)
|
| Technical Information (for support personnel)
| Go to Microsoft Product Support Services and perform a title search
for
the
| words HTTP and 403.
| Open IIS Help, which is accessible in IIS Manager (inetmgr), and
search
for
| topics titled Configuring ISAPI Extensions, Configuring CGI
Applications,
| Securing Your Site with Web Site Permissions, and About Custom Error
| Messages.
| In the IIS Software Development Kit (SDK) or at the MSDN Online
Library,
| search for topics titled Developing ISAPI Extensions, ISAPI and CGI,
and
| Debugging ISAPI Extensions and Filters.
|
|

****************************************************************************
*************************************************************
|
|
| So then some changes were made in IIS mgr then reversed and we now get
the
| following screen:
|
|
| Server Error in '/' Application.
|
|
| The resource cannot be found.
| Description: HTTP 404. The resource you are looking for (or one of its
| dependencies) could have been removed, had its name changed, or is
| temporarily unavailable. Please review the following URL and make sure
that
| it is spelled correctly.
|
| Requested Url: /monitoring/perf.aspx
|
|
|
|
|
| Version Information: Microsoft .NET Framework Version:1.1.4322.2407;
ASP.NET
| Version:1.1.4322.2407
|

****************************************************************************
****************************************************************
|
|
| Even if I go to the Performance Reports on the console I get the same
exact
| message. Any ideas?
|
| Thx,
|
| D
|
|
|








.



Relevant Pages

  • SecurityFocus Microsoft Newsletter #49
    ... Subject: SecurityFocus Microsoft Newsletter #49 ... Microsoft Windows NNTP Denial of Service Vulnerability ... Microsoft IIS SSI Buffer Overrun Privelege Elevation Vulnerability ... Microsoft ISA Server H.323 Memory Leak Denial of Service... ...
    (Focus-Microsoft)
  • SecurityFocus Microsoft Newsletter #154
    ... MICROSOFT VULNERABILITY SUMMARY ... ISS RealSecure Server Sensor SSL Denial Of Service Vulnerabi... ... Roger Wilco Remote Server Side Buffer Overrun Vulnerability ... available for Microsoft Windows operating systems. ...
    (Focus-Microsoft)
  • SecurityFocus Microsoft Newsletter #77
    ... MICROSOFT VULNERABILITY SUMMARY ... Novell GroupWise Web Root Disclosure Vulnerability ... Microsoft Windows NT Security Policy Bypass Vulnerability ... CVS Server Global Variable Denial Of Service Vulnerability ...
    (Focus-Microsoft)
  • Re: after installing KB011829 OWA is not working anymore
    ... Windows Vista or IE 7.0 no longer includes support for the ActiveX control ... The resolution for this issue is to install hotfix KB 911829. ... and to the back-end server. ... Microsoft CSS Online Newsgroup Support ...
    (microsoft.public.exchange.connectivity)
  • SecurityFocus Microsoft Newsletter #153
    ... MICROSOFT VULNERABILITY SUMMARY ... ZoneAlarm Random UDP Flood Denial Of Service Vulnerability ... FloosieTek FTGatePro Mail Server Path Disclosure Vulnerabili... ... Microsoft Windows NetBIOS Name Service Reply Information Lea... ...
    (Focus-Microsoft)