Re: Outbound email messages are sent multiple times



Hi Charles

I have just been conducting some tests with our ISP with respect to this
issue and we have identified the issue as being to do with an error in the
handshaking between his smtp server and ours.

He shall be looking into the issue in more detail over the next few days and
hopes to identify whether the issue lies at his end or ours.

I have recreated the problem and have the logs you requested. However I
don't think I should take up any more of your time untill we have identified
at which end the fault lies. If the issues appears to be with the exchange
server I shall send you the logs together with any feedback from out ISP.

Thanks for your help.

Charlie

""Charles Yang [MSFT]"" <v-chayan@xxxxxxxxxxxxxxxxxxxx> wrote in message
news:x9RYpdbFGHA.1240@xxxxxxxxxxxxxxxxxxxxxxxx
> Hi Charlie,
>
> If I understand correctly, the issue exists only when you sent emails to
> multiple external emails address.
>
> The root cause might be caused by many factors, in order to isolate the
> issue, we may need to gather some more information:
>
> 1. Do you encounter any problem when sending emails to multiple internal
> users?
> 2. If you only send to less than 100 external email address, do you
> encounter such issue or not?
> 3. Please also help gather the SMTP log, you can refer to the suggestion
> below:
>
> First, enable SMTP log on your Default SMTP Virtual Server.
>
> a. Please open Internet Services Manager.
> b. Right click on "Default SMTP Virtual Server" and click Properties.
> c. On the General tab, please check the option "Enable logging".
> d. Select W3C Extended Log File Format from the list below.
> e. Click the Properties button. In the General Properties tab, please
> confirm the following settings:
> - Check the option Daily
> - Check the option "Use local time for file naming and rollover"
> - Confirm the setting for "Log file directory" to be
> "C:\WINNT\System32\LogFiles"
> - Check all the logging options on the Advanced tab.
>
> Second, reproduce the issue.
> Third, send me the log file under C:\WINNT\System32\LogFiles\SMTPSVC#" (#
> is a number. The number for the Default SMTP Virtual Server is 1). Also,
> provide the sender recipient, and time. You can send the log file to my
> mailbox v-chayan@xxxxxxxxxxxxx
>
>
> 1. Please also check the event log to see if there are any error events on
> Exchange transports, please also paste it to newsgroup.
> 2. If you enable the message tracking, can you check where it stops? You
> can check where the emails sent to? It should be important for us to
> identify the issue. You can follow the steps below to enable message
> tracking:
>
> 246856 How to enable message tracking in Exchange 2000 Server and in
> Exchange
> http://support.microsoft.com/?id=246856
>
> I really appreciate your effort on this issue, please feel free to post
> back your results. I will be here waiting for your updates.
>
>
>
> Best regards,
>
> Charles Yang (MSFT)
>
> Microsoft CSS Online Newsgroup Support
>
> Get Secure! - www.microsoft.com/security
>
> ======================================================
> This newsgroup only focuses on SBS technical issues. If you have issues
> regarding other Microsoft products, you'd better post in the corresponding
> newsgroups so that they can be resolved in an efficient and timely manner.
> You can locate the newsgroup here:
> http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
>
> When opening a new thread via the web interface, we recommend you check
the
> "Notify me of replies" box to receive e-mail notifications when there are
> any updates in your thread. When responding to posts via your newsreader,
> please "Reply to Group" so that others may learn and benefit from your
> issue.
>
> Microsoft engineers can only focus on one issue per thread. Although we
> provide other information for your reference, we recommend you post
> different incidents in different threads to keep the thread clean. In
doing
> so, it will ensure your issues are resolved in a timely manner.
>
> For urgent issues, you may want to contact Microsoft CSS directly. Please
> check http://support.microsoft.com for regional support phone numbers.
>
> Any input or comments in this thread are highly appreciated.
> ======================================================
> This posting is provided "AS IS" with no warranties, and confers no
rights.
>
>
> =====================================================
> When responding to posts, please "Reply to Group" via your newsreader so
> that others may learn and benefit from your issue.
> =====================================================
>
> This posting is provided "AS IS" with no warranties, and confers no
rights.
>
> --------------------
> | Reply-To: "Charlie Wetherall" <charlie@xxxxxxxxxx>
> | From: "Charlie Wetherall" <charlie@xxxxxxxxxx>
> | References: <uitusQtEGHA.3200@xxxxxxxxxxxxxxxxxxxx>
> <x6Gp0zMFGHA.224@xxxxxxxxxxxxxxxxxxxxx>
> | Subject: Re: Outbound email messages are sent multiple times
> | Date: Mon, 9 Jan 2006 12:59:25 -0000
> | Lines: 199
> | Organization: Online Support
> | X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
> | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
> | Message-ID: <e36m#xRFGHA.2444@xxxxxxxxxxxxxxxxxxxx>
> | Newsgroups: microsoft.public.windows.server.sbs
> | NNTP-Posting-Host: online2.gotadsl.co.uk 81.6.251.58
> | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.phx.gbl
> | Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.windows.server.sbs:235129
> | X-Tomcat-NG: microsoft.public.windows.server.sbs
> |
> | Dear Charles
> |
> | Thank you for your reply. In answer to your questions:
> |
> | 1. Is there any error event on the SBS event view, it should be some
error
> | log on the event view.
> |
> | There are no errors what so ever in the event log.
> |
> | 2. Do you have any problem when sending outbound emails to a self
created
> | distribution list with recipient less than 100?
> |
> | No - not that I am aware:
> |
> | 3. Is there any third party anti-spam software, please temporally remove
> it
> | to see if the issue can be resolved.
> |
> | No -there is no anti-spam software.
> |
> | 4. Where you create the distribution list, on your Exchange server or it
> is
> | a distribution list created by a remote mail server? If it is created by
> the
> | Exchange mail server, the number has been reached to limitation.
> |
> | We are not using distributions lists. I simply clicked on 'reply all' to
> an
> | email which had about 750 email addresses in the 'to' field. This
resulted
> | in me sending an email with 750 email addresses in the 'to' field. I
know
> | that there is nothing particulary wrong with this address list as I have
> | recieved many emails from other people on the same address list who used
> the
> | same method to send the email.
> |
> | FYI I use use Outlook 2003 as my email client.
> |
> | 5. You had also to contact with your ISP to see if there are any
> limitation
> | on their side to send the emails to a large distribution list.
> |
> | I have checked with the ISP and there are no such limitations.
> |
> | We also have this same issue with one of our clients (we are an IT
Support
> | company). They also use MS Small Business Server 2003
> |
> | Thank you for your assistance.
> |
> | Best wishes
> |
> | Charlie Wetherall
> |
> |
> |
> |
> |
> | ""Charles Yang [MSFT]"" <v-chayan@xxxxxxxxxxxxxxxxxxxx> wrote in message
> | news:x6Gp0zMFGHA.224@xxxxxxxxxxxxxxxxxxxxxxxx
> | > HI Charlie,
> | >
> | > Welcome to SBS newsgroup.
> | >
> | > I am sorry for the delayed response due to weekend. Please understand
> that
> | > the newsgroups are staffed weekdays by Microsoft Support professionals
> to
> | > answer your systems and applications questions. Your understanding is
> | > greatly appreciated!
> | >
> | > Issue description:
> | > ================
> | >
> | > I understand that you encountered problem when sending emails to a
> | > distribution list larger than 100 recipient.
> | >
> | > Analyzing and suggestion:
> | > ==================
> | >
> | > Generally speaking, the issue should be caused by many factors, in
order
> | to
> | > isolate the issue, we need to gather more information:
> | >
> | > 1. Is there any error event on the SBS event view, it should be some
> error
> | > log on the event view.
> | > 2. Do you have any problem when sending outbound emails to a self
> created
> | > distribution list with recipient less than 100?
> | > 3. Is there any third party anti-spam software, please temporally
remove
> | it
> | > to see if the issue can be resolved.
> | > 4. Where you create the distribution list, on your Exchange server or
it
> | is
> | > a distribution list created by a remote mail server? If it is created
by
> | > the Exchange mail server, the number has been reached to limitation.
You
> | > can refer to the following KB article:
> | >
> | > 238569 OL: (CW) Problem Adding a Large Number of Items to a
Distribution
> | > List
> | > http://support.microsoft.com/?id=238569
> | >
> | > 5. You had also to contact with your ISP to see if there are any
> | limitation
> | > on their side to send the emails to a large distribution list.
> | >
> | > I really appreciate your effort on this issue, please feel free to
post
> | > back, I am glad to be of assistance.
> | >
> | >
> | >
> | > Best regards,
> | >
> | > Charles Yang (MSFT)
> | >
> | > Microsoft CSS Online Newsgroup Support
> | >
> | > Get Secure! - www.microsoft.com/security
> | >
> | > ======================================================
> | > This newsgroup only focuses on SBS technical issues. If you have
issues
> | > regarding other Microsoft products, you'd better post in the
> corresponding
> | > newsgroups so that they can be resolved in an efficient and timely
> manner.
> | > You can locate the newsgroup here:
> | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
> | >
> | > When opening a new thread via the web interface, we recommend you
check
> | the
> | > "Notify me of replies" box to receive e-mail notifications when there
> are
> | > any updates in your thread. When responding to posts via your
> newsreader,
> | > please "Reply to Group" so that others may learn and benefit from your
> | > issue.
> | >
> | > Microsoft engineers can only focus on one issue per thread. Although
we
> | > provide other information for your reference, we recommend you post
> | > different incidents in different threads to keep the thread clean. In
> | doing
> | > so, it will ensure your issues are resolved in a timely manner.
> | >
> | > For urgent issues, you may want to contact Microsoft CSS directly.
> Please
> | > check http://support.microsoft.com for regional support phone numbers.
> | >
> | > Any input or comments in this thread are highly appreciated.
> | > ======================================================
> | > This posting is provided "AS IS" with no warranties, and confers no
> | rights.
> | >
> | >
> | > =====================================================
> | > When responding to posts, please "Reply to Group" via your newsreader
so
> | > that others may learn and benefit from your issue.
> | > =====================================================
> | >
> | > This posting is provided "AS IS" with no warranties, and confers no
> | rights.
> | >
> | > --------------------
> | > | Reply-To: "Charlie Wetherall" <charlie@xxxxxxxxxx>
> | > | From: "Charlie Wetherall" <charlie@xxxxxxxxxx>
> | > | Subject: Outbound email messages are sent multiple times
> | > | Date: Fri, 6 Jan 2006 15:16:50 -0000
> | > | Lines: 25
> | > | Organization: Online Support
> | > | X-Priority: 3
> | > | X-MSMail-Priority: Normal
> | > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
> | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
> | > | Message-ID: <uitusQtEGHA.3200@xxxxxxxxxxxxxxxxxxxx>
> | > | Newsgroups: microsoft.public.windows.server.sbs
> | > | NNTP-Posting-Host: online2.gotadsl.co.uk 81.6.251.58
> | > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftngp13.phx.gbl
> | > | Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.windows.server.sbs:234602
> | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
> | > |
> | > | Hiya
> | > |
> | > | I have this problem when sending emails where the recipient list is
> very
> | > | large (over 100 but under a 1000).
> | > | The emails remain in the outbound smtp queue and are resent over and
> | over
> | > | again. I am then forced to cancel the mailing by deleting the
messages
> | > from
> | > | the outbound queue
> | > |
> | > | I think that possibly the smarthost recieves the message but not the
> | > entire
> | > | recipeint list and so my server then tries to resend the message by
> | > starting
> | > | all over again.
> | > |
> | > | The reason that I think that this might be the case is because some
> | > | recipients complain of recieving the message 20 or 30 times and some
> may
> | > not
> | > | recieve it at all.
> | > |
> | > | My connection time out has been set to 10 minutes and the Smarthost
> | > provider
> | > | is not aware of any issues on their end
> | > |
> | > | Any suggestions on how to fix this issue would be greatly
appreciated.
> | > |
> | > | (Incidently this has nothing to do with the well published issue
> | > concerning
> | > | the POP3 connector - as the pop3 connector on my server is not
> enabled)
> | > |
> | > |
> | > |
> | >
> |
> |
> |
>


.