DNS client resolver bug in Windows Server 2003?



DNS client resolver bug in Windows Server 2003?
===================================

Background:
------------

One AD forest
One AD tree
Two AD domains
One AD domain is a child (sub) of the other.

I don't wan't to post proprietary details here, so let's call these domains:

domain.com
subdomain.domain.com

I have about 300 servers in the environment.
It's a mixture of 2000 and 2003 servers.

About 240 servers belong to the "domain.com" domain.
About 60 servers belong to the "subdomain.domain.com" domain.

Of those 60 servers in the "subdomain.domain.com" domain, a little less than
half (25) are 2003 and the rest are 2000.

Issue:
------

I have no name resolution problems on anything that is a member of the
"domain.com" domain - regardless of whether or not those servers are 2000 or
2003.

The 2000 servers that are members of the "subdomain.domain.com" domain, only
are resolving everything properly - no problems.

However the *2003* servers that are members of the "subdomain.domain.com"
domain are having issues resolving short (unqualified) hostnames for servers
that belong to the "domain.com" domain.

Testing name resolution from these 2003 servers using NSLOOKUP resolves
everything fine.
However, testing name resolution from these 2003 servers using PING gives
back "could not find host".
Looking at the client resolver cache with IPCONIFIG /DISPLAYDNS gives back
that the host just tried "name does not exist".

So, I'm ONLY having this problem on my 2003 servers, not any 2000 servers
that are part of the same sub-domain, point to the same internal DNS servers
(in the same order), and use the same DNS suffix search settings.

I've tried setting DNS suffix search settings both explicity (putting both
domains in the "Append these suffixes (in this order)", and alternatively by
instead selecting "Append primary and connection specific suffixes" and
selecting the "Append parent DNS suffxes" option.

No matter what I do in that DNS screen, I have issues resolving stuff on
"domain.com" domain from the 2003 servers (ONLY) on the
"subdomain.domain.com" domain. Again, works fine from my 2000 servers on the
same domain, using the same DNS servers, accessing the same hosts.

Any ideas?
Is there a hot-fix for this?

.



Relevant Pages

  • Re: Help SMPT Errors
    ... FAIL Reverse DNS entries for MX records ERROR: The IP of one or more of your ... it may mean that your DNS servers did not respond fast enough). ... INFO NS records at parent servers Your NS records at the parent servers ... PASS Parent nameservers have your nameservers listed OK. ...
    (microsoft.public.exchange.admin)
  • Re: Replication issues
    ... I wanted to say Zone Transfers not Zone Forwarding. ... on 2 servers out of 4 DNS servers. ... DNS and 2003 DNS and how to set up Conditional Forwarding. ...
    (microsoft.public.windows.server.active_directory)
  • Re: Windows 2000 logon process
    ... Paul Williams ... when clients are accessing the GPO stored in SYSVOL during logon. ... PW>> Sound's like - that's a combination of DNS and Dfs client pointing ... Global Catalogue servers? ...
    (microsoft.public.win2000.active_directory)
  • Re: Howto refresh IIS 6 Application pool identity credential info
    ... You already have 80% of the work setup (DNS Aliases and HostHeaders) on the ... domain accounts (one for each layer) should be sufficient. ... The Application Servers are load balanced clustered, ... as the account name and SPN alias is correctly defined on both nodes. ...
    (microsoft.public.inetserver.iis.security)
  • Re: ad and dns setup
    ... domain It gave me 2 errors, no dns servers have dns records for this dc ... error no logon servers.. ... Make sure that the _msdcs zone exists and the scope is set to ... MCSE, MVP Directory Services ...
    (microsoft.public.windows.server.active_directory)