Unable to print in a workgroup


I was working on a 2 PC Windows XP Home SP2 workgroup and I was unable to get a shared printer to print from one of the PCs. The PC hosting the printer was an older Dell Dimension desktop which could print without issues, and the other PC in the workgroup was a Dell laptop (Latitude?). The PCs are connected through a Linksys WiFi router (the laptop is wireless, the desktop wired). The printer is set to be shared, and both PCs can access the internet, and ping each other successfully. Running the Add Printer wizard on the laptop at the beginning of all this, and selecting "browse the network for printers" did list the printer share, but when I tried to select the share (or if I tried to enter the \\servername\sharename manually) all that happened is a small dialog box labeled "Connect to compnamehere..." appeared, asking for a password to log onto the desktop PC as "\\compname\Guest". The Guest accounts on both PCs were active, and *as far as I know* had no passwords protecting either one. Needless to say, whenever I tried to enter a blank password, or enter the password "guest" or "Guest", this dialog box errored out with an "access denied" or similar message. Running the Network Setup Wizard on both PCs changed nothing. I changed the desktop PC's computer name and the printer share's name, which did nothing (but see below). I tried to perform "net print \\compname\printershare" from the laptop to the shared printer, and I received this error: "System error 1385 has occurred - Logon failure: the user has not been granted the requested logon type at this computer" or something to that effect. I tried to create a user account with the same name, privileges and password on both PCs to see if that would allow access to the printer share, but no dice. The printer share did not appear in the Add Printer wizard under "browse network for printers" after I changed the desktop PC's "computer name" and the printer share's name, although the computer name did appear. A "net print" from the desktop PC to the laptop worked without any errors. Both PCs are set to use the same workgroup, MSHOME. Finally, I tried to disable the Windows Firewall on both PCs, even though both reported that File and Print Sharing was being allowed through the firewall. Interestingly, on the desktop PC, I was unable to turn off the Windows Firewall through the control panel applet, because the option was greyed out. The only option I could choose was the "Don't allow exceptions" checkbox. At the top of the window, a message read something like this: "Due to security concerns, Windows Firewall is being controlled by group policy". As stated above, both machines have XP Home SP2 (actually, I believe the laptop had XP Media Center, but it definetly had SP2 installed). I was totally unable to access the group policy editor on the desktop (for obvious reasons).

Any ideas?

Thanks very much in advance for your help. I apologize for the imprecise nature of the above problem description, but unfortunately I don't own the machines in question and I'm not near them.

Thanks again and cheers!