Boot loop & ACPI BSOD's solved with disabling APM in BIOS



I have a question about what I did to get around the ACPI bsod's with
my ASUS mobo.
I solved the problem using the scheme outlined below in my previous
message. My question is, should I expect any adverse effect from
disabling APM in BIOS setup? It appears that Windows may be
auto-enabling APM on login.


On Mon, 14 Jul 2008 13:08:24 -0500, UKnowWho@xxxxxxxxxxxx wrote:

Strangest thing here. After reading some other forums on the ASUS
boards, I came across this possible fix; at least it worked for me.
Here is the quote from the forum: "Don't disable ACPI. First clear
CMOS and then go in Bios and disable APM and serial port. Don't
disable perallel port.
If you try to install Win XP SP3 a USB drive or a USB stick on a USB
port may solve the problem."

In short, I went into BIOS setup, did NOT disable the parallel port,
did NOT clear CMOS, and only disabled the APM, rebooted, and VOILA! It
works! No more "boot loop" or BSOD. BTW, I had been using the trick of
plugging in my USB Blackberry on boot up and that was working too.

I don't actually know what is happening when I disable the APM in the
BIOS. I still have ACPI compliant computer, according to Device
Manager. So far I haven't seen any adverse effects yet, but it's only
been a few hours, and 3 reboots.
Previous to this "fix" if I connected my Blackberry cell phone to the
USB port before boot up, then the system boots normally.


On Sat, 26 Apr 2008 18:11:00 -0700, prince1142003
<prince1142003@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote:

The ACPI 2.0 BSOD is a 0x7F stop error with a 0D parameter.
The ACPI 3.0 BSOD just says the BIOS is not fully ACPI-compatible.

I've already checked and rechecked every system component, including stress
testing the RAM for errors. The max temperature on any system component is
60°C on the GPU. The max CPU temperature is never above 45°C. I've cleaned
the case for dust and checked to ensure all system fans are working. Since my
PC works fine with ACPI 1.0, I doubt it's the power supply's fault.

Basically, what I'm wondering is if I need to make any driver-level changes
within Windows if I change the ACPI feature set version in the BIOS.

"Gerry" wrote:


Without the full Stop Error I can only provide the following.

Background information on Stop Error message
http://msdn2.microsoft.com/en-us/library/ms795478.aspx

0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP
One of three types of problems occurred in kernel-mode: (1) Hardware
failures. (2) Software problems. (3) A bound trap (i.e., a condition
that the kernel is not allowed to have or intercept). Hardware failures
are the most common cause (many dozen KB articles exist for this error
referencing specific hardware failures) and, of these, memory hardware
failures are the most common.
Source: http://aumha.org/a/stop.htm
In essence you have two areas where the problem could be. A software
problem ehich could difficult to determine and a hardware problem where
it is easier to eliminate some of the possibilities. I gave a link
regarding ttouble shooting hardware:
http://www.elephantboycomputers.com/page2.html#Hardware_Tshoot

Dust inside the computer casing can cause overheating and result in this
type of error. Take the casing off and use an Air Duster to clean. Also
check that all fans are working.

Try HD Tune(freeware) as you can see the SMART
information relating to the drive etc.

Download and run it and see what it turns up.
http://www.hdtune.com/

Select the Info tabs and place the cursor on the drive under Drive
letter and then double click the two page icon ( copy to Clipboard )
and copy into a further message.

Select the Health tab and then double click the two page icon ( copy to
Clipboard ) and copy into a further message. Make sure you do a full
surface scan with HD Tune.

You need then to test the RAM. Please refer to the link on how to do
this.

If these measures do not identify the cause of the problem you would be
best to seek professional help. The power supply unit can only be tested
by swapping in a replacement and most home users do not have a spare one
to use. The software diagnosis is beyond the capabilities of most users.

--



Hope this helps.

Gerry
~~~~
FCA
Stourport, England
Enquire, plan and execute
~~~~~~~~~~~~~~~~~~~





prince1142003 wrote:
Every time I switch my BIOS to ACPI 3.0, I get a BSOD saying my PC
isn't ACPI-compatible. I've also noticed that when using ACPI 2.0, I
get BSODs when resuming from hibernation. These BSODs have the
generic 0x7F stop error.

My System:
AMD Athlon64 X2 4600+
ASUS M2R32-MVP
2GB Corsair DDR2 RAM
Windows XP Professional SP2

Anyone know what's wrong, and what I could do to fix these errors?



.



Relevant Pages

  • Re: repair install
    ... disabling it or could there be something else in bios i havnt seen...bios ... see how your current BIOS ... > look for ACPI compliancy changes). ... (Obviate the Risk w/ Repair) ...
    (microsoft.public.windowsxp.general)
  • Re: Mobile Intel Pentium(R) 4 - M CPU 2.60GHz - kernel 2.6.3
    ... Perhaps with ACPI disabled you've left CPU frequency control in the ... There may be some BIOS ... > after disabling ACPI and such, those options do not seem to work ...
    (Linux-Kernel)
  • Re: acpi_tz0: WARNING - current temperature (61.0C) exceeds safe limits
    ... It's already been disabled in the bios but it still keeps ... Have you tried disabling ACPI at boot and running it that way for a while? ...
    (comp.unix.bsd.freebsd.misc)
  • Re: em driver, 82574L chip, and possibly ASPM
    ... Those are 82576, not 82574, totally different hardware. ... One of the proposed workarounds is disabling "Active State Power ... I have disabled it in BIOS but I don't know how to disable it in FreeBSD ... vendor = 'Intel Corporation' ...
    (freebsd-net)
  • Re: Mobile Intel Pentium(R) 4 - M CPU 2.60GHz - kernel 2.6.3
    ... throttling your CPU to keep it cool. ... If you can't disable this BIOS ... then running Linux with ACPI enabled and the processor ... >> after disabling ACPI and such, those options do not seem to work ...
    (Linux-Kernel)