Re: USB problem





"Paul" <nospam@xxxxxxxxxx> wrote in message
news:hkmcfq$g8q$1@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Steve T wrote:
Running XP-SP3 with all updates current. I have a WACOM tablet, driver is
latest version; plugged into a USB port in rear of DELL PC. I'll boot up
and get error message,"USB device not recognized...". I check Device
Manager and no flags are showing. I simply plug into another USB port and
I get message that "Human Interface Device found" and my tablet now
works. The next day I boot up and the same error message pops up and the
fix is to reverse what I did the previous day, just plug back into
yesterday's "bad USB port". Any ideas what I am chasing here? Thank you,
Steve T.

I don't know what exactly your problem could be, and the following are
just some leads to tools and suggestions.

*******

Implicit in what you're saying here, is unplugging it and plugging it
into the *same* port, isn't getting the device recognized. That you
have to change ports for it to work.

Today, it booted up the PC and the tablet was lit up thus no error messages.
Later, after awakening the PC; the error message returned regarding "USB
device not recognized..." I unplugged USB and plugged back into same port
and tablet was back on. I uninstalled software for tablet, rebooted and
noted that power light was not on tablet. During install of software for
tablet, it indicated that there was a problem as there was no tablet found
(plugged in entire time). I unplugged cable, re-inserted into same location
and Install proceeded. Now I'm waiting to see what happens next. Next time
it screws up I'll unplug for two minutes and see what happens.

To test Russ's theory that the issue is electrical, try unplugging it
for two minutes (sufficient time for a Polyfuse to recrystallize), then
plug it into the *same* port. If it malfunctions on the same port again,
the implication would be it is a software problem.

In terms of overcurrent protection on a port, on a desktop it is likely
to be implemented in pairs. The connectors on a "stack of two" USB ports
are likely connected to the same Polyfuse. Moving the USB cable from one
port in a "stack of two", to the other, should not materially affect the
electrical powering situation, and if there was an overcurrent problem,
the
misbehavior should continue once you move from one port in the stack
to the other. All my motherboards here are fused in such a way. Laptops
seem to be different, in that a laptop may use a silicon device for
controlling overcurrent, and a small 8 pin DIP cuts off the current.
Laptops should be much more precise about overcurrent, as a result.
And the laptop policing of current flow, should be separate for each
port.

I haven't tried looking through the registry for it, but USB
devices are remembered from one usage to another. For example, if
the USB device has a serial number, then Windows can give a more
consistent
response to the device, as it would recognize it had been used before.
If a device doesn't have a serial number, then each plug-in causes
re-installation (perhaps using built-in software stacks such as
HID or USB Mass Storage).

You can look in the file "setupapi.log" and see installation activity
at work.

You can also use UVCView, to look at the config data coming from the
device.
I doubt that is going to help in this case, because all you're going to
see, is no endpoints set up for the failed case, and endpoints set up
in the success case. (UVCView is a Microsoft program, no longer offered
for download. The copies on archive.org were also removed, presumably
at Microsoft's request.)

*******
ftp://ftp.efo.ru/pub/ftdichip/Utilities/UVCView.x86.exe
http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe

File size is 167,232 bytes.
MD5sum is 93244d84d79314898e62d21cecc4ca5e

This is a picture of what the UVCView info looks like.

http://www.die.de/blog/content/binary/usbview.png

Some information on the parameters seen in UVCView.

http://www.beyondlogic.org/usbnutshell/usb5.htm
*******

That leaves some kind of registry issue. There are some
troubleshooting suggestions here, for various sets of
symptoms.

http://www.uwe-sieber.de/usbtrouble_e.html

An example of removing USB so all devices can be
rediscovered, is detailed here.

http://www.usbman.com/Guides/Cleanup%20Device%20Manager%20Safe%20Mode.htm

Paul


.



Relevant Pages

  • usb_insert_transfer panic with if_zyd
    ... When I use my ZyXEL G-220 Wireless USB Stick with the if_zyd driver, ... <ACPI PCI bus> on pcib0 ... device problem, disabling port 1 ... <Ethernet over FireWire> on firewire0 ...
    (freebsd-current)
  • 2.6.10-rc1 & ahci & IHC6R & 925X & raid1
    ... usb modules for console, usb keyboard, network and starting a shell. ... ACPI: PM-Timer IO Port: 0x808 ... PCI: PCI BIOS revision 2.10 entry at 0xfb768, ... usbcore: registered new driver hub ...
    (Linux-Kernel)
  • usb does not work on vias smp mainboard
    ... I installed kernel 2.4.21 on an via's mainboard, it seems that the usb ... number of MP IRQ sources: ... PCI Interrupt Link ... Port indicators are not supported ...
    (Linux-Kernel)
  • Re: sata_nv times out for BD-ROM iHOS104-08
    ... generic IDE driver loaded? ... ACPI: PM-Timer IO Port: 0x4008 ... CPU: Physical Processor ID: 0 ... USB 2.0 'Enhanced' Host Controller Driver ...
    (Linux-Kernel)
  • Boot time Bluetooth BUG: warning: (value > m) at hid-core.c:793
    ... When the USB reciever is already plugged-in at boot-time and the ... hub 2-2:1.0: USB hub found ... Interface Descriptor: ... Hub Port Status: ...
    (Linux-Kernel)