Re: using HDDerase



astron wrote:

"David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in message news:j8ccqg09e3@xxxxxxxxxxxxxxxxxxxx
From: "astron" <astron@xxxxxxxxxxxxxxxxxxxxxxxxxx>


"David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in message
news:j8c58g0aoo@xxxxxxxxxxxxxxxxxxxx
From: "astron" <astron@xxxxxxxxxxxxxxxxxxxxxxxxxx>

After secure erasing 2nd(slave) hard drive with HDDerase.exe utility,
2nd hard
drive(slave) is not listed anymore in My Computer, but it shown in
Hardware >>>> Device Manager. What is the problem?

LOL ;-)

Its a raw drive with no partition scheme that Windows can assign a drive
letter to and
thus wiull NOT be shown in Explorer.




This makes things clearer. But how to resolve issue I mentioned above, BIOS
show error "Primary Slave Hard Disk Error", press F1 to Resume. ?

I don't know. It would depend on the computer, hard disk and BIOS revision.

The BIOS looks at the hardware and communicates to the BIOS (firmware) embedded on the hard disk. It then sends the system BIOS the drive parameters (heads, cylinders & sectors per track).

When the user views the CMOS Setup they are running a routine in the BIOS that queries information set about the hardware in CMOS memory.

The fact that you used the text "2nd(slave) hard drive" is indicative of an older PC that has an IDE/EIDE (aka; PATA) interface. Thus will most likely have two IDE Channels cable of up to four IDE devices.

When the user views the CMOS Setup they should then be able to see the assigned drive parameters (heads, cylinders & sectors per track) or the hard disk model.

If Yes then there is good communication with the hard disk hardware and the information will be passed onto the installed Operating System. Presumably you have Windows XP (as you posted in this group) and in the WinXP "Device Manager" you can see the hardware.

Pretty much, that's all that counts. The drive can now be re-formatted using the OS.

It is possible that the un-named system using the un-named BIOS and BIOS version could be looking for a marker on said hard disk that was removed and thus the error message.
If the drive can be formatted under WinXP, its a moot point.
If the drive can NOT be formatted under WinXP then you would have to use the un-named hard disk manufacturer's disk utility to see if the drive can be revived (so to speak). The un-named hard disk manufacturer's disk utility would know how to fully communicate with its hardware and would give further indication one way or another.


--
Dave
Multi-AV Scanning Tool - http://multi-av.thespykiller.co.uk
http://www.pctipp.ch/downloads/dl/35905.asp
----------
The disk shown in Device Manager as "Disk Drive", when right click on it, there are NO option for partitioning or formatting disk. There is option Disable, Uninstall, but this not change anything.

<resend - server problems>

I tried the HDDERASE program here.

I used a Seagate 7200.7 80GB drive.

I used the HDDERASE.iso and made a boot DVD with it, and used that
to run the command.

The program waits while the erase command is running. It took 42 minutes
to complete, during which time the hard drive light was on. By calculation,
it should have taken 30 minutes to do the erasure, so it was a bit slow.
(30 minutes at average benchmark rate should have been enough to complete
the entire 80GB disk).

The program also wrote the MBR with the details of the erasure. I was
able to verify that by reading the MBR later and examining the data with
a hex editor. And the confirmation of erasure was printed in there. The
adjacent sectors contained all 0's, so that was the pattern used internally
by Secure Erase (drive didn't support Enhanced option).

When Windows next started, and that disk was connected:

1) BIOS made no complaints. There were no "Primary Slave Hard Disk Error"
type errors. Presumably that error is a SMART error ?

2) Windows had an entry in Device Manager, under Disk Drives ("ST380011")

3) Disk Management shows an uninitialized 80GB drive. The wizard popped up
and wanted to write a signature on the drive. I canceled that. I used
the initialize button on the left in Disk Management, to turn the disk
into a Basic disk.

4) I was able to make a partition on the drive after that. Now, it has
a single 80GB partition, as proof it's working.

So I had no problems with mine.

I had significant problems with the usage of MSDOS for this task.
It's a pain in the ass, because it insists on only the primary four
disk interfaces be used. On my current machine, the IDE interface is
done with a separate chip, and MSDOS couldn't see it. So the
HDDErase program had no menu items to select from, and could not
erase the disk.

On my "legacy" machine, I put the IDE hard drive on a ribbon cable
and it was seen fine. The problew on that machine was a bit different.
I was booting MSDOS from a SATA DVD. That uses Extended INT 0x13 as
far as I know. But when the setup tried to load a CDROM driver, of
course the CDROM driver can't see the SATA interface, and so I
couldn't actually access the copy of HDDErase which was on the R:
CDROM image. Yet, the rest of the boot files, used to boot the
system (on Q:) were visible. THe MSDOS ISO on the HDDErase download,
is one of those "oversized" setups, with floppy sized boot volume, but
also a separate CDROM section, and that's the part that wouldn't mount.
To fix that, I had to plug an IDE2SAT adapter into the back of the
DVD drive, and connect it to the ribbon cable, and then, with all
devices on ribbon cables, I was able to use HDDErase.

So no significant problems here, and no broken hard drive. The
HDDErase program seemed to work. And the disk did show up in Disk
Management just fine.

Paul
.



Relevant Pages

  • Re: Hard disk failing check > mobo strange behaviour
    ... I ran the Seatool test and result confirm that all the ide connectors are ok but the hard disk is failing. ... as long as one of the drives is a Seagate etc. ... The BIOS has the ability to store info in two places. ... If the flash chip is wearing out, ...
    (microsoft.public.windowsxp.hardware)
  • Re: Grub hangs - two hard drives and a CD
    ... > What you wrote is all based on a wrong assumption that grub numbers drives ... > that the BIOS will call to boot an OS. ... The Bios calls to read disk require the register DL to ...
    (comp.os.linux.setup)
  • Re: About Windows 8 (UPDATE)
    ... Asus boot screen straight to the bootloader. ... flashed to the latest BIOS last week. ... The solution was in "disk management." ... When installing a new OS I always have to reassign their drive letters to get them out of the way of the real drives, but all drives do appear with no special help from disk management. ...
    (alt.comp.periphs.mainboard.asus)
  • Re: Not able to boot from SCSI disk on SYM21002 but all other works
    ... The BIOS itself needs accesss to drives of course to boot and so on. ... is no disk with DOS-reachable formatted partitions on or there is no ...
    (comp.periphs.scsi)
  • Re: HARD DISK Compatibility
    ... PCI adapter card, which has its own disk controllers and its own BIOS. ... drives, ...
    (microsoft.public.windowsxp.hardware)