Re: Cannot find ///FAST Hardlock Driver!


What you're encountering seems to be a problem with some type of copy protection scheme. This could be software that requires the use of a physical "key" or dongle to run.

I did find a download for the HardLock driver. But it doesn't give much information, except how to install it.

More information on HardLock can be found here:

Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart Display\Security
Win 95/98/Me/XP Tweaks and Fixes
Per user Group Policy Restrictions for XP Home and XP Pro
Please reply only to the newsgroup so all may benefit.
Unsolicited e-mail is not answered.

"Homeboy" <Homeboy@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message news:42FEEBD5-3E39-4825-801A-091DA391E4AE@xxxxxxxxxxxxxxxx
In another message, I am seeking information on how to repair XP Pro since I
think that is my problem. However, it might not be. I had avoided posting the
basic problem, because I’ve done it before without success and it’s a whole
lot of typing. Also, if you do a Yahoo or Google search you will see others
with the same problem, but no adequate fix seems to have been posted. But
here goes.

I am running XP Pro on a Dell computer with 4 gig of RAM. Among the various
programs on my machine is Wasatch Softrip, a PostScript interpreter that
requires a USB hardware key (dongle) to operate. It is loaded and operates
fine. Another program on the machine was B-Coder, an older program which, the
manufacturer claims, works find in the XP environment. And in fact it did.
Later I loaded RentRight, another older program on the machine (which is said
to work fine in XP) and it too worked. But then I removed RentRight from the
machine and in so doing – I assume – I removed or modified something that
impaired the ability of these older programs to operate. After that, when I
tried to run B-Coder, the machine would freeze for maybe 30 seconds, then I
would get the following message: "Cannot find ///FAST Hardlock Driver!� with
an OK box. Click OK and another window would appear that said: “HLVDD.DLL. An
installable virtual device driver failed Dll initialization. Choose ‘close’
to terminate the application" with two boxes: “Close� and “Ignore.� If you
chose ignore, the application starts but an MS error box appears that says:
“NTVDM.EXE has encountered a problem and needs to close� along with an option
to send error info to MS (or not). If you leave that box open you can still
operate the program but if you close the NTVDM box, the application shuts
down. If you close the application either by choosing “Close� or closing the
NTVDM box, several times, eventually, you will get another box that says:
“Can’t run 16-bit Windows program. Insufficient memory to run his
application. Quit one or more Windows applications and then try again.� This
last error message works just as indicated. If you go to the Windows Task
Manager and make sure all the pieces of the old programs are closed, you can
open them again (as far as they will go) without the memory error message.

I contacted Wasatch, RentRight and B-Coder. None of the three know anything
about the problem. At some point, I got word that a company called Aladdin
had something to do with a Hardlock Driver. I contacted them and they, too,
could provide no help since they don't know of B-Coder or RentRight.

Eventually, I deleted these programs from the Dell computer and ran them on
another computer also running XP Pro. It doesn’t have the Wasatch program or
the dongle, but remember the programs rather fine with Watsatch and the
dongle before I removed one of them.

The reason this is coming up again is that I am retiring the computer that
is currently running RentRight and B-Coder. I’d like to put it on the same
Dell that had the program before. I loaded RentRight and am getting the error
messages I outlined above.

Here is a note I found using an Internet search from someone who is
apparently having the same problem.

Posted by shepard:
I don't know what I did to my computer but now everytime a msdos 16 bit
subsytem starts, it freezes for about 30 secs, then displays "cannot find ///
FAST Hardlock Driver, after that a window appears with hlvdd at the top and
then says " an installable virtual device driver failed dll initialization".
I tried to restore to an earier point, but with no luck. I am using xp home
2.4g, 80g hd, 1g ram.
Posted by mojo7819:
Windows XP does not contain msdos. If you can get a dos program to run on
XP, consider
yourself extremely lucky!! Chances are, it will not run in XP.
Posted by shepard:
Hi mojo, I don't agree with your idea because I used to use same programs
without any error but somehow my XP started to give that error messages. I
guess I installed or uninstalled something and then this happened. I'm trying
to find it.

Here is another answer to shepard’s post:

I had the exact same problem after ghosting my main hard disk onto a new
computer. Turned out to be because one of the programs installed on my drive
used Alladin for copy protection. Note that Alladin is a software only copy
protection. (Elsewhere someone suggested that this was related to dongle copy
protection. It is not.) This causes DOS programs to die even though I was not
running the copy protected program!!! When I found the offending program and
uninstalled it all my DOS programs started working again. So the moral of the
story is - Be suspicious of every program you have installed. One of them
probably uses Alladin.

I haven’t examined all my other programs to see if any use Aladdin [correct
spelling] for copy protection since I don’t know how to begin that process.
It sounds daunting. However I did go to the Aladdin website today and found
some hardlock drivers.

(I didn’t notice these when I tried to solve the problem months ago.) You
think I could just download one of these and solve the problem, or does that
have the potential to make things worse? Which one should I download? 32
because I’m running XP or 16 because apparently that’s the program giving me
the problem?

I’m not at all a techie, but the circumstantial evidence seems to indicate
that on the Dell machine a Windows file or a registry entry is missing or has
been changed or corrupted. I am trying to re-install Windows without removing
all my programs and data, but am having issues with that process. But what I
have outlined here is the only reason I am trying to do a Windows re-install.
Perhaps someone has a better solution.


Relevant Pages

  • Re: failed admin pak installation - w2k3
    ... The Windows Installer service cannot update one or more protected Windows ... Jabez stated: "Disable Windows File Protection." ... I can install this admin pak in my test environment w/o any issue. ... our production servers and the installation fails with "Windows File ...
  • Cannot find ///FAST Hardlock Driver!
    ... Later I loaded RentRight, another older program on the machine (which is said ... Quit one or more Windows applications and then try again.” ... had something to do with a Hardlock Driver. ... used Alladin for copy protection. ...
  • Re: How well does the Windows Vista Firewall work?
    ... Assuming you haven't somehow disabled Windows Defender you have a reasonable amount of protection as far as anti-malware software is concerned. ... If you are on a web site and you are prompted to install or allow something unexpectedly don't do it. ...
  • RE: AntiVirus MalWare SpyWare Protection
    ... Also what if I installed 'Windows Defender', ... along with Windows FireWall be enough protection for my system without any ... Microsoft Security Essentials provides real-time protection for your home PC ... simple to install, easy to use, and always kept up to date so you can be ...
  • Blaster Worm CSP installation on W 2000 ME
    ... >I have Windows 2000 ME installed on my system and this ... >Blaster Worm? ... Assuming I need to install the patch for protection, ...