Re: What is WmiApRpl service for ?



WmiApRpl.dll is the WMI Performance Reverse Adapter.

WMI is Windows Management Instrumentation service.

Windows Management Instrumentation (WMI) service
http://smallvoid.com/tweak/winnt/service/wxyz.html#WINMGMT

If you run DEFRAG or ProcessIdleTasks you'll get Event ID 1000 & 1001
LoadPerf.

Event ID: 1000
Source: LoadPerf
http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.0&EvtID=1000&EvtSrc=LoadPerf&LCID=1033

Event ID: 1001
Source: LoadPerf
http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.0&EvtID=1001&EvtSrc=LoadPerf&LCID=1033

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:eCh6uMnVGHA.5900@xxxxxxxxxxxxxxxxxxxx,
- Bobb - <bobb@xxxxxxxxxxxx> hunted and pecked:
Yesterday, on my Pc I noticed I had 2 version of Pc Anywhere: A Beta (
V11) and an earlier full version.
I went to control panel - uninstall beta and then it wanted to reboot - I
did so and then dll error problems.
I did a repair on full version - rebooted. Then OK, today I checked when
I booted and my App Event log shows:

Event Type: Information
Event Source: LoadPerf
Event Category: None
Event ID: 1001
Date: 4/2/2006
Time: 11:37:01 AM
Computer: AMD
Description:
Performance counters for the WmiApRpl (WmiApRpl) service were removed
successfully. The Record Data contains the new values of the system Last
Counter and Last Help registry entries.

followed by:

Event Type: Information
Event Source: LoadPerf
Event Category: None
Event ID: 1000
Date: 4/2/2006
Time: 11:37:01 AM
Computer: AMD
Description:
Performance counters for the WmiApRpl (WmiApRpl) service were loaded
successfully.
then the same 2 entries again - no entries after that.

I've looked at MS and Google search - I can find other references to this
service online but I can't find out WHAT is it ? and why is it appearing
today ? Maybe coincidence and only has to do with time change ?? Or is
it related to my PcAnywhere repair ?

On my PC , under system-manage and services, I only see: WMI Performance
Adapter - no WmiApRpl.

.