Re: TCP/IP CP reported error 31



In news:nfgqe1l8p641r8mt91v5jjdd1c477q9cuk@xxxxxxx,
Bob Feigel <bob@xxxxxxxxxxxxxxxxxx> made this post, which I then commented
about below:
> My apologies if this isn't the right group to ask for help on this
> issue:
>
> OS: WIN2000Pro
> Pentium III & plenty of system resources to spare
> No hardware conflicts
>
> Problem: After I've accessed my dial-up connection more than four or
> five times in one session, I get the following error message:
>
> "Checking network protocol connections...
>
> TCP/IP CP reported error 31: A device attached to the system is not
> functioning."
>
> Details:
>
> "An internal error occurred.
>
> Make sure you typed your password correctly, and also make
> sure that you typed alphabetical characters in the correct
> uppercase or lowercase format.
>
> Restart your computer to make sure that all recent
> configuration changes have taken effect. If the error persists,
> consult the Windows 2000 event log for detailed warnings or
> errors.
>
> A possible cause of this error is that the connection was
> rejected because the remote computer exceeded its client
> license limit. Ask your system administrator to buy more client
> licenses or point you to a different remote computer."
>
> The event log shows the following error detail:
>
> "Windows cannot unload your registry file. If you have a roaming
> profile, your settings are not replicated. Contact your administrator.
>
> DETAIL - Access is denied. , Build number ((2195))."
>
> And warning:
>
> "The COM+ Event System failed to fire the Logoff method on
> subscription {2F519218-754D-4CFE-8DAA-5215CD0DE0EB}. The subscriber
> returned HRESULT 800706BA."
>
> I have no idea what all that means, whether it's even related to the
> problem or where I can find out. The only way I can reconnect is th
> reboot. Then it's OK for a while.
>
> I've tried Windows Help, the Microsoft Knowledge Base, this and other
> newsgroups and forums, but could not find any mention of this specific
> problem as it relates to my situation. I do not run a server and have
> a direct dial-up connection via a modem that tests OK.
>
> BTW - I haven't installed any new software - although I do update my
> spyware & antivirus definitions regularly.
>
> Also - this problem developed suddenly and without any obvious reason
> I can put my finger on.
>
> Any help would be appreciated. Thanks, Bob
>
>
>
>
>
> "It's not that I'm afraid to die. I just don't want to be there when
> it happens." - Woody Allen
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Wax-up and drop-in of Surfing's Golden Years:
> <http://www.surfwriter.net>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


Seems to me there's somethine else installed on the machine causing this. Do
you have an ADSL connection with the WinPoet software installed on this
machine? If so, check this:
http://www.mcse.ms/archive46-2004-8-996293.html

Did you have EZCD creator installed and rmoved it?
If so, check this.
Cannot Access CD-ROM and Code 31 Error Message in Device Manager After You
Remove Adaptec Easy CD Creator from Your Computer:
http://support.microsoft.com/kb/q270008/

Other related info:
http://forums.enterpriseitplanet.com/archive/index.php/t-934.html

You could also have malware or spyware installed causing this, as I've found
with some client machines, such as the NewDotNet client. It's a nasty one.
Here's info on how to remove it:
http://www.newdotnet.com/

Also, I would suggest to run a complete antivirus scan and perform some
anti-spyware procedures. For possible spyware, download, install, update and
run all of the following.

Ad-Aware
http://www.lavasoftusa.com/software/adaware/

Spybot search and destroy
http://www.safer-networking.org/en/download/

Microsoft Windows AntiSpyware (Beta)
http://www.microsoft.com/athome/security/spyware/software/default.mspx

If none of the above fixes the issue then download Hijack this, run
it, save a copy of the log file and post it to one of the forums below:

HiJackThis Download:
http://www.spywareinfo.com/~merijn/downloads.html

SWI Forums- Post your HiJackThis logfile (Powered by Invision Power Board):
http://forums.spywareinfo.com/

HiJackThis Tutorial and Forums-
How to use HijackThis to remove Browser Hijackers & Spyware. Post your
logfile here:
http://www.bleepingcomputer.com/forums/index.php?showtutorial=42


--
Regards,
Ace

Please direct all replies ONLY to the Microsoft public newsgroups
so all can benefit.

This posting is provided "AS-IS" with no warranties or guarantees
and confers no rights.

Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT, MVP
Microsoft Windows MVP - Windows Server - Directory Services
Infinite Diversities in Infinite Combinations.
=================================


.



Relevant Pages

  • Re: failures accessing commonly used webpages (eg. yahoo.com)
    ... And also your settings on the Connection tab. ... > runs on windows 98se and is connected via a linksys hardwired router ... > has any problem accessing webpages via IE6 or Mozilla'a firefox. ... I am tempted to remove windows 2000 and install windows ...
    (microsoft.public.windows.inetexplorer.ie6.browser)
  • RE: Windows Start Up Error
    ... then start by running TrendMicro's Sysclean ... After you have used Sysclean, install a full-featured av, update its ... scan with HijackThis. ... If you are running Windows ME or XP, ...
    (microsoft.public.windowsxp.general)
  • Re: Windows is great, except for a few things...
    ... Have you tried installing Dell Support 3.0 which will test your computer and ... I would also insert your Windows XP CD. ... After you install each, you should click update before running. ... > -My wireless network connection works fine but internet explorer won't ...
    (microsoft.public.windowsxp.help_and_support)
  • Re: Error 0x0000000d in network printer
    ... connection to a shared printer. ... Windows Printing Team ... Error message when you try to install a network printer on a Windows ... We have the following problem in 10 windows Vista Computers recently ...
    (microsoft.public.windows.vista.print_fax_scan)
  • Re: How to control LAN users?
    ... Shutting down the machines would work for me, there might be some unhappiness but I could deal with that, but what I'm really looking for is a way to open the connection to the internet at my discretion. ... Real VNC is easy to install on the windows boxes. ... If vncviewer is not in /usr/bin, ...
    (Fedora)