Re: F12 Not working



It's not an IIS permission thing, it's a NTFS permission issue.

Some (obvious?) questions:
How are you trying to open the file? What mode?
Does that file definitely exist? Or does your app create it?
What are the permissions on it?
What are the permissions on c:\inetpub\wwwroot\xxx\Resources\XMLFiles ?
Have you adjusted them since reinstalling, or just copied the files across
from your backup?

Jevon


"moondaddy" <moondaddy@xxxxxxxxxxxxx> wrote in message
news:ufUqges6FHA.2616@xxxxxxxxxxxxxxxxxxxxxxx
> Awesome!!! That worked. I didn't manually select any environment and just
> let everything take the defaults, but for some reason the environment was
> set to VS 6 (uhhhG).
>
>
> Another question which may be a long shot as it doesn't seem to belong
> here, but perhaps is related after all:
>
> I have a web project and my code needs to manually write data to an xml
> file. in order to make this happen I have to set the appropriate
> permissions on that folder (both in IIS and also windows explorer) so the
> user accounts ASP.NET and IUSR_MachineName have read/write permissions.
> However, now that everything has been completely reloaded on this machine,
> when ever the code tries to write to this file I get the error:
>
> "Access to the path
> ""c:\inetpub\wwwroot\xxx\Resources\XMLFiles\dsCacheClient.xml"" is
> denied."
>
> 11/16/2005 9:11:04 AM "at System.IO.__Error.WinIOError(Int32 errorCode,
> String str)
> at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess
> access, FileShare share, Int32 bufferSize, Boolean useAsync, String
> msgPath, Boolean bFromProxy)
> at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess
> access, FileShare share)
> at System.Xml.XmlTextWriter..ctor(String filename, Encoding encoding)
> at System.Data.DataSet.WriteXml(String fileName, XmlWriteMode mode)
> at wsVIPN.FileHelper.GetClientCash() in
> c:\inetpub\wwwroot\xxx\Libraries\FileHelper.vb:line 30"
>
> I can't recall what else might need to be set in order to allow writing to
> a file from with in a asp.net 1.1 website.
>
> Any good ideas?
>
> Thanks again.
>
>
>
> --
> moondaddy@xxxxxxxxxxxxx
> "Jevon" <please@xxxxxxx> wrote in message
> news:O4CbDVs6FHA.1000@xxxxxxxxxxxxxxxxxxxxxxx
>> Which environment have you selected under the My Profile tab of the Start
>> Page? You might find you've selected a different keyboard scheme this
>> time around.
>>
>> Jevon
>>
>>
>> "moondaddy" <moondaddy@xxxxxxxxxxxxx> wrote in message
>> news:O7MRqur6FHA.3588@xxxxxxxxxxxxxxxxxxxxxxx
>>> It doesn't work in new or old projects. I just created a new project
>>> and it doesn't work there. I did however, add a GoTo Definition button
>>> to the toolbar and that button worked. For the test I created a private
>>> var:
>>> Private str As String
>>>
>>> and added a reference to it like this:
>>>
>>> Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As
>>> System.EventArgs) Handles Button1.Click
>>> str = "xxxxxxxxxxx"
>>> End Sub
>>>
>>> When I put the cursor in 'str' and hit F12 nothing happens, but then
>>> when I click on the GoTo Definition toolbar button it takes me to the
>>> definition as expected.
>>>
>>> Any idea what the hang-up is?
>>>
>>> Thanks.
>>>
>>> --
>>> moondaddy@xxxxxxxxxxxxx
>>> ""Gary Chang[MSFT]"" <v-garych@xxxxxxxxxxxxxxxxxxxx> wrote in message
>>> news:zSLn0Lp6FHA.1236@xxxxxxxxxxxxxxxxxxxxxxxx
>>>> Hi,
>>>>
>>>>>I just reformatted my HD, reloaded the OS and all applications
>>>>>on my dev machine. Now that VS2003 is reloaded on the
>>>>>machine and I'm starting towork in it again, I noticed that the
>>>>>F12 doesn't work anymore.
>>>>
>>>> Would you please tell me does this problem occur to the new project in
>>>> VS2003?
>>>>
>>>> If the F12 shortcut key doesn't work for the new VS2003 project
>>>> neither,
>>>> does its corresponding context menu command work, I mean the "Go TO
>>>> Definition" command.
>>>>
>>>>
>>>> Thanks!
>>>>
>>>> Best regards,
>>>>
>>>> Gary Chang
>>>> Microsoft Community Support
>>>> --------------------
>>>> Get Secure! ¡§C www.microsoft.com/security
>>>> Register to Access MSDN Managed Newsgroups!
>>>> http://support.microsoft.com/default.aspx?scid=/servicedesks/msdn/nospam.asp
>>>> &SD=msdn
>>>>
>>>> This posting is provided "AS IS" with no warranties, and confers no
>>>> rights.
>>>>
>>>
>>>
>>
>>
>
>


.