VISTA Error Message while using EasyCleaner



Whenever I run the Temp Internet Files clean in EasyCleaner, at the end of
the process, when you would normally delete all temp files, I get this error
message. It's sort of an error message/dialog box.
The title bar reads "Microsoft Windows".
The main message reads, "Easycleaner executable has stopped working."
Below that it goes on and on with "A problem caused by.... blah blah blah"
At the bottom, is a CANCEL button. That is ALL YOU CAN DO IS PRESS THAT
CANCEL BUTTON, AND all your scan time has been for NOTHING! The software then
shuts down! It's maddening.
I first unchecked the box in User Accounts for UAC before I ran it. I
installed the software as Administrator. I right clicked on EasyCleaner icon
and RUN as Administrator, BUT every time I run EasyCleaner on my friend's
laptop, who is running VISTA, at the very END of the Temp Internet Folder
scan, just at the point where you would delete all the Unnecessary files
found, I get this freaking Windows Vista ERROR MESSAGE!
It's her first time ever running EasyCleaner and she always has about 12,000
Unnecessary files in her Temp Internet folder. I've tried this numerous times
and the same thing happens every time.
Like I said, I unchecked the UAC box and I ran as Administrator, and I still
get that error message!
What is the deal? How can I get rid of those damn Temp files? I've used the
built in Disc Cleanup feature, and that does not get rid of even a third of
them.
It only seems to happen with the Temp Internet files part of EC, but not
with any of the other files such as Normal Types, Extra Types, Temp
Directories, etc...
I can't even seem to browse to the actual folder by using the pathname.
What is the backdoor fix on this?
A little help here would be greatly appreciated.

.