RE: Cannot set up 3rd-party ftp server on VISTA



alright, I just had a friend of mine try my ftp server, and he could log on!!
so, I just cannot see my own ftp in my explorer window when it is running on
my vista computer (this was possible before on XP). But I guess, this doesn't
bother me as much now, since from the outside people can connect.

Thanks for your help though. At least I know it is working, although I
cannot see it.

PS. did manage to get it to work with the SmartFTP client now, running
explicit FTP, not normal FTP.

Den


"axelm" wrote:

I read some of your previous posts again and if I understand correctly you
did this test:

1) Remove router.
2) Connect Vista machine directly to the cablemodem
3) Disable Windows Firewall.
4) Start FTP server listening on 0.0.0.0:21/tcp
5) Open ftp client and connected to 127.0.0.1:21 and it worked fine.
6) Using the same client you connected to your internet address (which is
the same address your network adapter has) and you were not able to establish
an ftp connection. Yo can check your external IP address by going to
http://www.whatismyip.org .

Are you sure your ftp server is configured to allow non-LAN connections? I
sometimes use Filezilla and IIRC the default config is to only allow
connection from your local subnet and localhost.


"axelm" wrote:

Tryport forwarding ports 20/tcp and 21/tcp. Sounds like your router is not
handling the ftp control port correctly. Check if your router has a "special
applications" section and if FTP is listed there use that instead of a manual
port forward.

The reason is the FTP has some issues with NAT and usually a special
nat-helper is required.

"Fly" wrote:

sorry, i forgot to mention it is a cable modem. I do have a public IP
address, no need for a password. (the 192.168.0.102, is the address given to
my comp by the (wifi) router.)
I am not sure whether it is a static address or dynamic. But starts with
63.x.x.x

Still, don't understand why this would not affect my other computer, though,
if something was up with the router or the cable modem. hmm, puzzling.
Mind-boggling.

Thanks again.

Den

"axelm" wrote:

Definitely sounds like your ADSL modem is in router mode. You are adding an
extra (wifi?) router behind the ADSL modem, then you AT LEAST have a double
NAT.

You could have and additional NAT layer if your ISP is giving you a private
address (usually 10.x.x.x) instead of a public internet address. This is
usually not the case, but I have seen this happen woth some el-cheapo ISPs.

If this were my network I'd put the ADSL modem in bridge mode and set the
router to PPPOE and try from there. Do you have the password to change the
ADSL modem config? Do you know your PPPOE user and password? Maybe you can
contact you ISP and tell them that you have set up a wireless router and that
you want to reset the ADSL modem to bridge mode. They should be able to help
you if your contract allows more than one PC.

"Fly" wrote:

You mean 192.168.0.102...(i set the ports for this also in the router).
I'll have to post the ipconfig /all later as I don't have access to my
computer at the moment.

I believe the router is DHCP configured, I would have to check that as well.

But wouldn't this also affect my other XP computer running on that router?

Thanks,

Den

"axelm" wrote:

What IP address does your ADSL modem serve via DHCP? Please post the output
from ipconfig /all. If your ADSL modem is in router mode instead of bridge
mode then you have to port forward that too.

Regarding your router, how do you configure the WAN adapter? DHCP or PPPOE?

"Fly" wrote:

127.0.0.1 works, I see my files. (I assume this is what you meant by
localhost?)
But ftp://(my ISP address x.x.x.x) does not work, neither in the explorer,
nor in the FTP client SmartFTP.

Directly connected to the modem (without router) does not work.
But my other computer's FTP server is working fine, so the ports in the
router were set the right way.

It is also showing 0.0.0.0:21 and some other 50000-50004

Windows firewall is off, so no ports to be set there I suppose.
And even when turning off the McAfee firewall, I cannot get through.

Den

"axelm" wrote:

0.0.0.0:50000 means it accepts connections from all the network adapters.

Have you tried moving it to port 21 just for testing purposes? Remember that
FTP uses two ports, and usually the firewall has to be FTP-aware.

Have you tried connecting to the FTP server from the LAN side? What about
localhost?

Axel

"Fly" wrote:

I have a problem setting up ftp server, such as serv-U or Bulletproof FTP on
my new computer running Vista. On my old one I could set it up in 5 min. This
is also still working, so my router is not the problem.
I have McAfee, but I gave the program full access, no other options
available, even when turning McAfee firewall off, no connection. Windows
firewall is turned off.

It has to be a Vista security issue. Does anybody have ANY idea. I do not at
this point. In Windows defender you can see networking component or something
like this, and the Serv-U, SmartFTP, or Bulletproof show up but it seems they
are not listening on a specific address. Just 0.0.0.0:50000 etc. and no
foreign address.

Can anyone help me?

Den Fly
.