Return of XP-Vista Networking Hell



Its been about three months since I've given up trying to network my Vista
machine with my XP machine, but I thought I would try it again.

Some people were helping me, and I thank them, sorry for not updating my
post, but there was nothing to update.

Anyway here are my symptoms again:

*Vista (Ultimate) machine cannot see XP (Home SP2) machine.
*XP machine can see and access the Vista machine.
*Xp machine shows up in the Vista Network Map, but not the Network Folder.
*Both machines can ping each other.
*I can access the XP machine via IP address, I can access the shared folder
but not a shared printer.
*IPConfig for Vista shows that NetBIOS over TCP/IP is disabled even though
it is enabled in the Network Adaptor Properties dialog. (NetBIOS over TCP/IP
always enabled, the middle radio button)

Other information:
*Everything worked as it should once apon a time, then it all went to Hell.
It could have been an update, tweaking software, or antivirus setting, but I
notcie too late to do anything about it.
*I know it can't be that I don't have the same User/Password on both
machines (I tried it anyway but it still didn't work), because it worked
awhile back without having the same accounts on both machines.
*I had Bitdefender 2008 on the Vista machine, the Firewall log had entries
that the ports 138 and 139 were being refused, despite having the XP machine
being on the trusted list (by its IP address). So I uninstalled the
Antivirus, but the problem persists.
*The XP machine has Zone Alarm Internet Security.
*I have an Archos Media Player. It can act as a file server and can connect
to a network like a regular computer. It can see the XP machine and the XP
machine can see it. The Vista machine cannnot see it , and the Archos Media
Player cannot see the Vista machine. The Vista machine and Archos Media
Player can see each other when networking worked. I believe the OS is Linux
based.
*I have a Linksys WRT350N router.

I can only conclude something is wrong with the Vista machine only, as all
other devices are working like they should.
I have the following settings in the Network and Sharing window in Vista:
*Network: Private
*Network Discovery: On
*File Sharing: On
*Public Folder Sharing: On (Read Only)
*Password Protected Sharing: Off
*Media Sharing: On

I will post my IPConfig for my Vista machine in a reply. Thanks for reading
this far at least, any help is appreciated.
.