'Share' options missing



I am trying to help someone running Vista Home Premium setup his network to
share files and folders with his XP Home laptop.

Oddly enough, there are no share options AT ALL. No share buttons or no
share options in the context menus -- NOTHING.

We've named the network and simply went out to share a printer (which we
DO have the option to share) -- but when we share it, sharing simply turns itself off. Same in Network and
Sharing Center. We turn the options ON and then they turn themselves OFF. We've
done all the rebooting, etc. and still no go.

I have gone through all the disabling of the UAC and ownership and
permissions, et. al. but, can't get anywhere without the SHARE OPTION being
available. Is his install of Windows Vista Home Premium broken or needing to
be reinstalled? Could that be the problem? Could it have been set up
improperly? Not even sure if that's a valid question.

I have successfully done this before on my Vista Business computer and my XP
Pro laptop and although i did have a few 'permission' problems, they were at
least workable and i worked them out, but this one has me stumped.

Can someone help?
Thanks so much in advance.
Susan

.