Re: WMP11 does not play asf files, missing Sharp G.726 Audio codec



I do not care much of Media Foundation codeces. I think WMP should play ASF
without renaming it to ASX. My Irfanview for instance can play those files
without need for renaming. The question is NOT in codeces. The WMP seems to
be crapware. I want that Microsoft makes a fix for the problem. Under Windows
XP everything is fine! Vista + WMP sucks!

"zachd [MSFT]" wrote:


As far as I'm aware, Sharp doesn't have a Media Foundation codec available,
so this is expected. If Sharp provided a Media Foundation compatible G.726
codec, then this would work. =\

--
Speaking for myself only.
See http://zachd.com/pss/pss.html for some helpful WMP info.
This posting is provided "AS IS" with no warranties, and confers no rights.
--
"Sults" <eesnimi.perenimi@xxxxxxx> wrote in message
news:91709EE4-41F4-4444-B044-8CEE2D2A61BE@xxxxxxxxxxxxxxxx
When I try to watch videos recorded with my camcorder in ASF format, I
will
get following WMP11 error message:
"An audio codec is needed to play this file. To determine if this codec is
available to download from the Web, click Web Help."

If I press Web Help button, I will be directed to the web page, that gives
me following information:
"Windows Media Player cannot play the file (or cannot play either the
audio
or video portion of the file) because the Sharp G.726 Audio (45) codec is
not
installed on your computer."

But as soon as I rename file to ASX, the WMP11 plays file correctly. On my
other computer (Windows XP) I can watch those videos without problems.
What's wrong with WMP11 on Vista?


.