Re: Missing Hard Drive with Windows Vista Ultimate




January 2009

I have the same issue on a HP DV9810us Laptop running Vista SP1.

On this laptop, if I put a Western Digital 120G hard drive in the
second bay, it dissapears when resuming from sleep.

I discovered that if I put a Toshiba 120G drive in the second bay
instead, this problem doesn't appear!!

With the WD drive, I tried setting the sleep time to "Never", but this
didn't make any difference.

On further investigation (both drives are known to be good), it turns
out that the WD drive use the default Microsoft SATA device handler,
where as the Toshiba drive uses it's own device driver.

This definitely points to a MS SATA device driver issue.

MS SATA Driver details:
Driver Provider: Microsoft
Driver Version: 6.0.6001.18000
Driver Date: 6/21/2006

I tried running "Driver Update", but Microsoft reported that this was
the most up to date driver at this time (January 14th 2009)

Western Digital doesn't provide any updated drivers (or any drivers for
that matter) from their web site.


--
pcarew
.



Relevant Pages

  • [2.6 patch] remove the documentation for the legacy CDROM drivers
    ... This patch removes the documentation for the removed legacy CDROM drivers. ... SC1200 WDT DRIVER ... LaTeX document on standardizing the CD-ROM programming interface. ... THIS DRIVER WILL WORK WITH THE CD-ROM DRIVES LISTED, ...
    (Linux-Kernel)
  • [PATCH 18-rc2] Fix typos in /Documentation : N-P
    ... Again, if you're not gonna do synchronization with disk drives (dang, ... -the kernel. ... There are two options specific to PSX driver portion. ... The driver uses the settings from the EEPROM set in the SCSI BIOS ...
    (Linux-Kernel)
  • Re: [PATCH, RFT, v4] sata_mv: convert to new EH
    ... check both new and old drives with SMART ... Use a HIGHMEM enabled kernel. ... ACPI: PM-Timer IO Port: 0xe408 ... Real Time Clock Driver v1.12ac ...
    (Linux-Kernel)
  • Re: Help! Major Memory Installation Issue
    ... the "HD Audio Driver and Application" option. ... all on my C or F drives. ... Dig into the archive of installers ...
    (alt.comp.periphs.mainboard.asus)
  • Re: 2.6.27-rc1-mm1: rmmod ide-cd_mod oops
    ... Which IDE host driver is it happening with? ... unable to handle kernel NULL pointer dereference at 00000024 ... # Please see Documentation/ide/ide.txt for help/info on IDE drives ... # PCI IDE chipsets support ...
    (Linux-Kernel)