Re: MOSS 2007 crawl never ends



the solution for us was http://support.microsoft.com/kb/930887/en-us .

hope it woks,
wulf

"Peter Lawton" wrote:

Bit more info

If I stop the full crawl by deleting all the records from all the tables
with a crawlID column, I can happily run incremental crawls without any
problems, but the next full crawl hangs up and never ends

Peter Lawton

"Peter Lawton" <devnull@fakedomain> wrote in message
news:ucK8E2AJHHA.2632@xxxxxxxxxxxxxxxxxxxxxxx
Damn, it fixed it for the first full manual full crawl, then when it did a
scheduled full crawl last night it never stopped again, still running this
morning :(

Peter Lawton

"Peter Lawton" <devnull@fakedomain> wrote in message
news:ebVcYr3IHHA.1252@xxxxxxxxxxxxxxxxxxxxxxx
Great - that seems to have fixed it, thanks :)

I wish I knew what I was doing to break it though, I've re-build this
test server about 15 times now and the search service always ends up with
the first full crawl never ending.

I expect it's something I'm doing wrong and do wrong every time, but I've
no idea what.

Peter Lawton

"Hardeep" <Hardeep@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:EE34F997-E1DE-4C61-865F-78D1AA0F7529@xxxxxxxxxxxxxxxx
Here is the solution to fix it:
1. Go to SQL Server database SharedServices1_Search_DB and delete the
records from all the tables with crawlID column (ex. CrawlHistory
table).
2. This will stop the crawl
3. Create a new SharedService with new database using SharePoint
Centeral
Admin
4. Set new Shared Service to default
5. Delete the old Shared Service
6. Setup the crawl rules and run the full crawl

You'll get clean search crawl results.

Hardeep


"Peter Lawton" wrote:

Same problem here too

stsadm -o osearch -action stop

Doesn't stop the crawl

There must be some way to fix this :(

Peter Lawton

"Daniel" <Daniel@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:DC545D57-8BF3-4BA7-8FCB-D9586C95CCAB@xxxxxxxxxxxxxxxx
One more thing. When i run the "stsadm -o osearch -action stop"
command
the
status is still "Crawling" after an half hour. The Crawling seems to
be
unable to stop and so seems the osearch service!

I need help with this issue.

/Daniel

"Daniel" wrote:

Hi,

I also experience the same problem with the crawler that never ends.
There
are no Errors in the Eventlog or Crawl log indicating any type of
problem.
The search works fine except that the crawler never ends, seems like
its
stuck in an neverending loop after some 20 000 items in the index.

This is a great problem that must be fixed immediatly becuse this
problem
occurs on a production server and it seems to be an obvious bug in
the
system. The server is latest MOSS2007 Release Version.

/Daniel

"Mike" wrote:

I had this problem and following command fixed it:

stsadm -o osearch -action stop
stsadm -o osearch -action start -role indexQuery

This will stop the microsoft office search service and restart it.

Mike.

"Peter Lawton" wrote:

I'm having a lot of problems with the indexer on MOSS 2007, it's
starts a
full crawl and never ends.

I can't stop the crawl or reset the index from central admin,
can't
even
stop the mssearch service from the services control panel it
just
sticks at
"stopping"

I've installed it clean about 10 times now and even with no
content,
just a
couple of site collections, once a full crawl starts it never
stops
and ends
up with over 3000 connections to the search database.

W2003 32bit front end and a separate SQL 2005 x64 back end.

Anyone come across this and found the cause?

I'm getting desprate now and I've spent a week re-building MOSS
2007
from
scratch over and over again, every time I get the same problem.

Thanks

Peter Lawton













.