Re: ODBC worked until Server reboot defaulted to windows authentic



I got the exact spelling of the windows login with the case and I rebooted
several times
and got the exact login. I still cannot login from the datasource. The
file is a Filemaker 10 file I need to migrate the data from Filemaker to SQL
Server. The odbc source is set up in windows and that connects on the test.
The SQL Server Mgmt studio connects also but only as Windows authentication.
There is no other instance that I can see that works so that probably isn't
it. I cannot connect to Mgmt studio to sQl server with the sa password. I
moved the dialog to authtenticate with sa password inserted the password that
definitely worked before and it no longer works. I really don't want to
reinstall the server.
thanks for your help.

"Erland Sommarskog" wrote:

Janis (Janis@xxxxxxxxxxxxxxxxxxxxxxxxx) writes:
I installed SQL Server Express 2005. I choose Mixed MOde Authentication
and then installed it.
...
However, my laptop lost connection to the internet. I had to reboot and
SQL server defaulted to Windows authentication mode.

Probably because you had changed authentication to Windows only. The
setting does not take effect until SQL Server is restarted.

However when I connect from the ODBC database and run a script I get
errors on entering the login and password. My SErver is called :
JANIS\SQLExPRESS (SQL Server 9.0.1399 - JANIS\janis)

9.0.1399 is the RTM version of SQL 2005. While it may not resolve your
issues, there is all reason to download and install Service Pack 3.

So I try the login JANIS\SQLEXPRESS with my network password? That
doesn't work.

Where do you try this? When you log in with Windows authentication, you
log in without specifying username or password; you always log in with
the same user as you have logged into Windows.

NOw I can't run a script from the ODBC data source even though the ODBC
connection tests positive and I can login to the server via SQL SErver
mgmt studio with the sa password.

IT asks for the password and login. The sa password doesn't work nor
does the computer login and password work.

This is where it gets difficult. You have some piece of software, here
only identified as "ODBC data source", which try to log in to SQL Server
but which apparently fails. From what you said, I would assume that you
have everything on the same machine, but I am not sure.

If you are able to log in as sa through Mgmt Studio, there should be
no differences. Here are a few things to examine:

o Make sure that you are logging into the correct instance, and not
some other instance.
o Make sure that you enter the password exactly, and keep in mind that
it's case-sensitive.
o If there are non-ASCII characters, this may cause problems if the
applicaition is a command-line program.
o As I said above, you cannot specify a Windows login, when you log
in with Windows authentication.



--
Erland Sommarskog, SQL Server MVP, esquel@xxxxxxxxxxxxx

Links for SQL Server Books Online:
SQL 2008: http://msdn.microsoft.com/en-us/sqlserver/cc514207.aspx
SQL 2005: http://msdn.microsoft.com/en-us/sqlserver/bb895970.aspx
SQL 2000: http://www.microsoft.com/sql/prodinfo/previousversions/books.mspx

.

.



Relevant Pages

  • Re: Credentials not being passed with remote access
    ... allowed windows authentication to work, ... I had assumed johnx was a domain user rather than a local Windows account. ... johnx was set up as a local login on sql server. ...
    (microsoft.public.sqlserver.security)
  • Re: Granting permission to a database - need help
    ... Windows authentication, and not use an application login, as then ... Links for SQL Server Books Online: ... USE Driver Access ...
    (microsoft.public.sqlserver.programming)
  • Re: login 101..
    ... On Windows 2003, SQL Server 2005 can enforce the Windows password complexity ... Windows authentication - SQL Server uses a special protocol to ask ... user is in the list of allowed logins, ...
    (microsoft.public.sqlserver.security)
  • Re: Granting permission to a database - need help
    ... folder and it would have the database connection info. ... Windows authentication, and not use an application login, as then ... Erland Sommarskog, SQL Server MVP, esquel@xxxxxxxxxxxxx ...
    (microsoft.public.sqlserver.programming)
  • RE: How to create a trusted connection
    ... You need to grant access for the Windows login by referring to the books ... is set to use Windows authentication to be able to do trusted connection. ... There are two modes of authentication in SQL Server: ...
    (microsoft.public.sqlserver.security)