Re: Problem bei Abfrage über WSH



Meine Frage bezieht sich auf die Thematik, die hier in der Newsgroup geführt
wird.
Was Sie haben weiß ich nicht, ist aber auch nicht wichtig für mich !

"asdf" schrieb:

Ich habe hier 2006.

Haben Sie computer oder windows Fragen ?




"Daniel" <Daniel@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:C58D33EA-5607-4B9A-BE26-F4FC58B31879@xxxxxxxxxxxxxxxx
Nein, bitte richtig durchlesen´-> Windows 2000 Server und 2003-Server.

Wer lesen kann ist klar im Vorteil.

"asdf" schrieb:

Mann, muss ja weh tun !

win98se.





"Daniel" <Daniel@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:6893E2DA-1DAD-41B5-917F-3ACE34A16F13@xxxxxxxxxxxxxxxx
Hallo,
wir haben folgendes Script entwickelt um die Eventlogs über WSH
auslesen
zu
können.

***************
Msgbox("Testverbindung für Eventlogauslesen mit Kennung testadmin")
strServer=Inputbox("Bitte Printserver-Namen für Verbindungstest
eingeben:")
Set objLocator = CreateObject("WbemScripting.SWbemLocator")
Set objService = objLocator.ConnectServer(strServer, "root\cimv2",
"testdomäne\testadmin", "Passwort")
objService.Security_.ImpersonationLevel = 3
WQL = "SELECT * FROM Win32_NTLogEvent WHERE EventCode='10'"
Set Result = objService.ExecQuery(WQL)
MsgBox("Verbindung war erfolgreich")
************************

Auf W2K-Servern funktioniert das, nachdem die Berechtigung für den
User
natürlich korrekt gesetzt wurden (Remoteaktivierung etc. beim CIMV2).
Auf W2K3 erscheint die Fehlermeldung in Zeile 4/Zeichen1:"Der
RPC-Server
ist nicht verfügbar. Code 800706BA, Quelle SWbemLocator.

Den Tipp von MS, den Dienst Winmgmt neu zu starten oder zu beenden und
neu
zu starten, hat leider nicht geklappt.
Das WMI-Repository habe ich bis jetzt noch nicht neu erstellt.

Kann jemand weiterhelfen ?

Gruß
Daniel Schindler



.