Re: Zahlensystem-Umwandelung: Dezimal --> beliebige Basis, beliebige Elemente




Hallo Reinhard,

Ich möchte gerne eine Spalte mit Dezimalzahlen in eine 2.Spalte mit einem
anderen Zahlensystem mit einstellbarer Basis umwandeln. Die Elemente des
Zahlensystems sollen von mir vorgegeben werden können (um bestimmte Buchstaben
im Alphabet zu vermeiden), z.B.:
0123456789ABCGHKLM

Witzig. Gerade gestern wollte eine Kollegin eine Liste von dreistelligen
Zahlen mit der Basis 33 und den Zeichen 0-9 und A-Z ohne die Buchstaben
I, O und Q.

Meine Lösung (hier Formeln für Zeile 2):
In Spalte A: Zahlen von 1- 35936
HilfsSpalte B: =GANZZAHL($A2/(33*33))
HilfsSpalte C: =GANZZAHL($A2/33)-(B2*33)
HilfsSpalte D: =REST(A2;33)
In Spalte E (das Ergebnis):
=SVERWEIS(B2;mtx;2;0) & SVERWEIS(C2;mtx;2;0) & SVERWEIS(D2;mtx;2;0)

wobei "mtx" ein Bereich ist, in dem in Spalte 1 die Zahlen 0 - 32 und in
Spalte 2 die zulässigen Zeichen 0 - Z stehen.

In Spalte E stehen dann die Zahlen von 001 bis ZZZ.

Vielleicht kannst Du das für Dich anpassen.


Gruß
Jörg
--
LPs auf CD brennen - so geht's: http://www.joergei.de/
E-Mail-Adresse existiert, wird aber nicht gelesen.
.



Relevant Pages

  • Re: Rechnen in Pivot-Tabellen
    ... Frank Vellner schrieb am 04.01.2007 ... Eine weitere Spalte "Anteil" ... identischen Wort von Basis B vergleichen (z.b. von einander subrahieren ... Vergleich habe ich in der Pivot Tabelle bislang nicht hinbekommen. ...
    (microsoft.public.de.excel)
  • Re: =?iso-8859-1?q?Suchen_und_erg=E4nzen?=
    ... Von oben nach unten sind sie daher nicht in alphabetischer ... Auf der Rückseite des Blattes steht das Alphabet von A-Z von oben nach ... Nun soll z.B. bei dem Buchstaben C automatisch das eingetragen werden, ... in Tabelle1 steht die Gradzahl in Spalte A, die Stadt in Spalte B und der ...
    (microsoft.public.de.excel)
  • Re: =?ISO-8859-1?Q?Auslesen=2C_kopieren=2C_einf=FCgen=2C_kommagetrennt=2C_VBA?=
    ... In Spalte A stehen nacheinander Begriffe, ... einer beliebigen Anzahl von Buchstaben, i.d.R. sind es aber nur vier. ... Diese Ziffern und Buchstaben sollen ebenfalls getrennt werden, ... Code habe ich dazu keinen fertigen da. ...
    (microsoft.public.de.excel)
  • =?ISO-8859-1?Q?Auslesen=2C_kopieren=2C_einf=FCgen=2C_kommagetrennt=2C_VBA?=
    ... Office 2003 verwendbar) mit etwa 3500 Zeilen auseinander nehmen zu ... In Spalte D sind Ziffern-Buchstaben-Kombinationen vorhanden, ... einer beliebigen Anzahl von Buchstaben, i.d.R. sind es aber nur vier. ... Diese Ziffern und Buchstaben sollen ebenfalls getrennt werden, ...
    (microsoft.public.de.excel)
  • Anzahl ermitteln
    ... eine Liste der verschiedenen ... Werte in einer Spalte zu finden. ... Ich weiß vorher nicht, welche Buchstaben überhaupt vorkommen. ... mit SQL in Excel-Tabellen zu ...
    (microsoft.public.de.excel)