RE: Nach DC-Entfernung falsche GUID im AD > keine Replikation



Hallo Peer,

ich hatte mal ein ähnliches Problem. Glöst habe ich es so:
1. Fehlerhaften DC vom Netz genommen
2. Per ntdsiedit die Leiche des neuen, falschen DCs entfernt
3. Verbliebene DNS-Elemente und Site-Elemente entfernt
4. Eventlog am nächsten Tag kontrolliert --> ok
5. Neuen Server mit NEUEM NAMEN per dcpromo integriert

Evtl. gibt es da noch andere Möglichkeiten, aber ich hatte derzeit keine
andere gefunden.

Viel Erfolg...

Gruß,
Bernd

"Peer Röhl" schrieb:

> Hallo
>
> Habe hier eine SingleDomain mit zwei Sites und jew. 2 DC's.
>
> Auf der Site1 habe ich DC2 nach Ausfall entfernen und neu aufsetzen müssen.
> Konnte vorher noch alle FSMO's auf DC1 der Site1 seizen.
> Außerdem habe ich vor der Neuinstallation auf DC1 der Site1 (und zwar nur
> dort)
> einen Metadata-Cleanup für DC2 durchgeführt.
>
> Jetzt habe ich das Problem, dass im AD der beiden DC's in Site2 eine falsche
> GUID für
> den neu aufgesetzten DC2 -der den gleichen Namen trägt wie der alte-
> eingetragen ist. (ich vermute die alte).
>
> Die DNS Server haben alle den richtigen (neuen) CNAME record für den DC2.
>
> Ich befürchte, dass ich den neu aufgestzten DC2 ans Netz genommem und
> promoted habe,
> bevor der Metadata-Cleanup an die Site2 repliziert wurde.
>
> Ich habe jetzt das Problem, dass die DC's aus Site1 zwar mit denen aus Site2
> replizieren können, aber
> nicht umgekehrt. (Zumindest behauptet dies DCDIAG)
>
> Wie kann ich jetzt am besten vorgehen?
> Kann ich den GUID einfach von Hand editieren? (wie und wo)
> Oder soll ich vielleicht vorübergehend den alten CNAME Record im DNS
> eintragen?
>
> Peer
>
>
>
.