Problem with MySQL connection



Hello,
I'm trying to get a CreateUserWizard asp component to connect to a MySql
Server. I've installed the latest Mysql connector.

THep roblem is taht even after modifying web, config to connect to the
MySQL server, the ASP.Net application send MS-SQL requests on port 3610
t03618 instead of a MySQL request to port 3306 (but it sends it to the
right IP address).


default.aspx:
<asp:CreateUserWizard ID="CreateUserWizard1"
MembershipProvider="userProvider" runat="server">
[...]


web.config:
<system.data>
<DbProviderFactories>
<add name="MySQL Data Provider" invariant="MySql.Data.MySqlClient"
description=".Net Framework Data Provider for MySQL"
type="MySql.Data.MySqlClient.MySqlClientFactory,
MySql.Data,Version=5.0.7.0, Culture=neutral,
PublicKeyToken=C5687FC88969C44D"/>
</DbProviderFactories>

</system.data>
<connectionStrings>
<add name="MySqlServer"
connectionString="Server=172.16.197.132;Database=ozone;Uid=xxxxx;Password=xxxx;"
providerName="MySql.Data.MySqlClient"/>
</connectionStrings>

<system.web>
<membership defaultProvider="userProvider">
<providers>
<add name="userProvider"
type="System.Web.Security.SqlMembershipProvider"
connectionStringName="MySqlServer" enablePasswordReset="true"
passwordFormat="Hashed" requiresUniqueEmail="true"
requiresQuestionAndAnswer="false"
minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="6"
passwordStrengthRegularExpression="" description="Looser requirements to
create users."/>
</providers>
</membership>
<roleManager enabled="true"/>
<authentication mode="Forms"/>
<compilation debug="true">
<assemblies>
<add assembly="MySql.Data, Version=5.0.7.0, Culture=neutral,
PublicKeyToken=C5687FC88969C44D"/></assemblies></compilation>
</system.web>

I've tried to add the Driver and Port attributes to connectionString,but
the compilations fails on them.

Any idea what I did wrong?

Thank you
.