Re: DX for managed code won't install



sorry, something con truncated there....

What are you asking the clients to install? If its just the DX9.0 redist
from here
http://www.microsoft.com/downloads/details.aspx?FamilyId=0A9B6820-BFBB-4799-9908-D418CDEAC197&displaylang=en
then it won't work becuase this contains only the core DX files, no D3DX and
no MDX (or possible very old version I can't remember)


If you have made your own installer and are using dxsetup then you must make
sure the .Net framework is already installed before calling DXSetup.
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/directx9_c/directx/directsdk/ProgrammingGuide/InstallingWithDirectSetup.asp


--
Zman
http://www.thezbuffer.com - News and information for Managed DirectX



"ZMan" <zman@xxxxxxxxxxxxxx> wrote in message
news:ud$Q2gG9FHA.2152@xxxxxxxxxxxxxxxxxxxxxxx
> What are you asking the clients to install? If its just the DX9.0 redist
> from here
> http://www.microsoft.com/downloads/details.aspx?FamilyId=0A9B6820-BFBB-4799-9908-D418CDEAC197&displaylang=en
>
> If you have made your own installer and are using dxsetup then you must
> make sure the .Net framework is already installed before calling DXSetup.
> http://msdn.microsoft.com/library/default.asp?url=/library/en-us/directx9_c/directx/directsdk/ProgrammingGuide/InstallingWithDirectSetup.asp
>
>
> --
> Zman
> http://www.thezbuffer.com - News and information for Managed DirectX
>
>
>
> "Elfreda" <Elfreda@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
> news:4A9858EE-841C-48E7-B3AC-20D7DD7A89AA@xxxxxxxxxxxxxxxx
>>I have inherited an application that uses directx. I had to make a couple
>>of
>> minor changes to the code and updated it to use directx 9.0c. Everything
>> worked fine on my development machine but on the clients' I get file not
>> found exceptions. It seems like the folders in
>> C:\WINDOWS\Microsoft.NET\Managed DirectX are not getting created and I
>> searched the registry and it also does not have the right entries for the
>> managed code dll's. I'm comparing to what exists on my machine.
>>
>> I have found posts about similar problems from 8 to 12 months ago but the
>> suggested fix (installing from the command line and setting a flag for
>> installing managed) doesn't work. Any ideas to get it to install would be
>> great.
>>
>> FYI I am using VS2003, .NET framework 1.1 and have the Oct SDK update.
>> Thanks
>
>


.