Re: Problems with Depth-Buffer

From: Philip Taylor [ATI] (ptaylor_at_online.newsgroup-poster.ati.com)
Date: 05/12/04


Date: Wed, 12 May 2004 15:40:36 -0700

do the samples with z-buffer render correctly?

if so, what do they do differently?

you are clearing the color and depth buffer every frame, right?

"Thomas" <tfeldkam@sagor.prima.de> wrote in message
news:2gfg5vF292rcU1@uni-berlin.de...
> Hello,
>
> I'm new in programming with DirectX.
>
> I want to use Depth-Buffer (Z-Buffer) in my Scene.
> So I'm using the following lines of code to create the device:
>
> myPresentParameters.AutoDepthStencilFormat=DepthFormat.D16;
> myPresentParameters.EnableAutoDepthStencil=true;
>
> In the Scene there is only a Mesh.Box-Object.
> If I don't use the Z-Buffer (comment out the lines of code above) the
Scene
> is rendered right.
> When I use the Z-Buffer, the facettes of the box are sprinkled by dots. So
I
> can't imagine the form of the box.
> I would be glad if anyone can help me, to solve this problem.
>
> cu Thomas
>
> P.S. I use a GeForce 4200TI to render the scene.
>
>



Relevant Pages

  • Re: Problems with Depth-Buffer
    ... well I didn't clear the depthbuffer every frame. ... > you are clearing the color and depth buffer every frame, ...
    (microsoft.public.win32.programmer.directx.managed)
  • Re: Z-Buffer problems rendering a Mesh
    ... doh. ... I wasn't clearing the z-buffer. ... thanx fro the help. ...
    (microsoft.public.win32.programmer.directx.managed)
  • Re: z
    ... All the documentation says "depth buffer". ... textbooks and DIRECT3D say "Z-buffer" these days. ...
    (comp.graphics.api.opengl)