RE: Graph in Report



The row source of my graph is:

PARAMETERS forms!ParamFormDept!StartDate
DateTime,forms!ParamFormDept!EndDate DateTime,forms!ParamFormDept!cboDept
Text; TRANSFORM Count(*) AS [Count] SELECT Format([Date of Complaint],"MMM
'YY") FROM [qryGraphbyDept] WHERE [Date Of Complaint] Between
forms!ParamFormDept!StartDate and forms!ParamFormDept!EndDate GROUP BY
Year([Date of Complaint])*12 + Month([Date of Complaint])-1,Format([Date of
Complaint],"MMM 'YY") PIVOT [Main Category Description]

I do not have the Link Master/Child properties field set. I'm thinking it
has to be something with my row source...however, just not sure of what I'm
missing....possibly something with the "WHERE" piece of the statment?



"Duane Hookom" wrote:

What is the full sql view of your Row Source?
Can we assume your form is open a values entered?
Do you have the Link Master/Child properties set to any values?

--
Duane Hookom
Microsoft Access MVP


"Amber" wrote:

I added this in the row source, and the graph is blank. If I leave the
cboDept blank, then it graphs for the correct time frame. But if I specify
the cboDept, the graph is blank. Below is what I added in the graph's row:

PARAMETERS forms!ParamFormDept!StartDate
DateTime,forms!ParamFormDept!EndDate DateTime,forms!ParamFormDept!cboDept
Text;

Otherwise, the rest of the row source remained the same. Is there something
else I need to add to have the graph capture the dept also?

Thanks!


"Duane Hookom" wrote:

Your query parameters provide the data types of the date control values but
not the cboDept. I would expect to see this in
PARAMETERS forms!ParamFormDept!StartDate
DateTime,forms!ParamFormDept!EndDate DateTime, ... right here ...;
--
Duane Hookom
Microsoft Access MVP


"Amber" wrote:

Hello-

I am trying to include a graph in an Access report. The graph report is
based off of a query. I built an unbound form named "ParamFormDept" with
three text boxes, StartDate/EndDate/cboDept that the user enters the date and
dept criteria into that they want the report for. When I run the query on
its own, the data comes up correctly. When I run the report with the graph
in it I get an error message saying "...does not recognize the name
[forms]![ParamFormDept]![cboDate] as a valid field name or expression."

My graphs row source says:
PARAMETERS forms!ParamFormDept!StartDate
DateTime,forms!ParamFormDept!EndDate DateTime; TRANSFORM Count(*) AS [Count]
SELECT Format([Date of Complaint],"MMM 'YY") FROM [qryGraphbyDept] WHERE
[Date Of Complaint] Between forms!ParamFormDept!StartDate and
forms!ParamFormDept!EndDate GROUP BY Year([Date of Complaint])*12 +
Month([Date of Complaint])-1,Format([Date of Complaint],"MMM 'YY") PIVOT
[Main Category Description]

I'm thinking my error must be related to something in the row source....my
question is what should the graph row source be?

Help is appreciated....thanks!



.